Project

General

Profile

Bug #11076

Starred environments are NOT suggested for promotion

Added by Christine Fouant about 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1238768
Description of problem:
The promotion web page has the text "Starred environments are suggested for promotion" However, non of the environments have a star.

Version-Release number of selected component (if applicable):
6.1.0 Compose 20150625.2

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
No starred envirnment

Expected results:
suggested environment is "starred"

Additional info:
see screenshot

Associated revisions

Revision 560a9991 (diff)
Added by Christine Fouant about 4 years ago

fixes #11076 - Adds star to suggested environment, BZ1238768

Revision c425f7d4
Added by Christine Fouant about 4 years ago

Merge pull request #5349 from cfouant/env-star

fixes #11076 - Adds star to suggested environment, BZ1238768

Revision 2a6654f0 (diff)
Added by Christine Fouant almost 4 years ago

fixes #11076 - fixes starred environments promotion suggestions, BZ1238768

This change is a revert of https://github.com/Katello/katello/pull/5349.

Revision 8af1b316 (diff)
Added by Christine Fouant almost 4 years ago

fixes #11076 - fixes starred environments promotion suggestions

This change is necessary because we were previously binding to the result of an expression instead of an expression itself. Thus, the ng-class directive would properly see the value of item.customClass but would not necessarily update based upon digest cycles.

Revision 57d4fad6
Added by Eric D Helms almost 4 years ago

Merge pull request #75 from cfouant/cv-promotion

fixes #11076 - fixes starred environments promotion suggestions

Revision a0641f7d
Added by Eric Helms almost 4 years ago

Merge pull request #5444 from cfouant/cv-promotion

fixes #11076 - fixes starred environments promotion suggestions, BZ1238768

History

#1 Updated by The Foreman Bot about 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5349 added
  • Pull request deleted ()

#2 Updated by Christine Fouant about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Eric Helms about 4 years ago

  • Legacy Backlogs Release (now unused) set to 70
  • Triaged changed from No to Yes

Also available in: Atom PDF