Project

General

Profile

Bug #11092

Web UI gets javascript error that crashes browser when viewing tasks

Added by Nathan Peters over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Complete steps from beginning to end to reproduce (Firefox browser):

1)Create a product
2)setup multiple external repos for that product
3)do a mass sync (I had 4 repos updating in this case) which will cause a parent task with subtasks to get created.
4)click on the tasks tab for the product.
5)Click the sub-tasks link which will bring you to the subtasks page (screenshot attached).
6)Wait for the page to reload and watch the errors start.

As you can see in the latest linked example, on the first reload, I get 3 copies of the menu bar, on the subsequent reloads, the entire screen fills up as linked in the first post.

Original report for reference : https://groups.google.com/forum/#!topic/foreman-users/hcHmr70IdJY

Screenshots attached.

javascript2.png View javascript2.png 70.2 KB Nathan Peters, 07/10/2015 03:04 PM
javascript.png View javascript.png 75.9 KB Nathan Peters, 07/10/2015 03:04 PM
Javascript2 Javascript

Associated revisions

Revision 295f3083 (diff)
Added by Ivan Necas over 6 years ago

Fixes #11092 - fix tasks reloading

The previous implementation often caused the browser to crash due to
way how the reloading was implemented. It also fixes the behaviour in
the two-pane mode variant.

Revision 6f4d47ca (diff)
Added by Ivan Necas over 6 years ago

Refs #11092 - fix multi-request polling

Eliminate the number of taskProgressReloader objects to one

Revision 5ecdb5a2
Added by Ivan Necas over 6 years ago

Merge pull request #126 from iNecas/fixes/11092

Fixes #11092 - fix tasks reloading

History

#1 Updated by Ivan Necas over 6 years ago

Thanks for the report, I've seen this as well, will investigate

#2 Updated by The Foreman Bot over 6 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-tasks/pull/126 added
  • Pull request deleted ()

#3 Updated by Ivan Necas over 6 years ago

The fix is ready for testing

#4 Updated by Ivan Necas over 6 years ago

  • Bugzilla link set to 1245485

#5 Updated by Ivan Necas over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF