Project

General

Profile

Bug #11131

Intermittent Puppet class cache test with timestamps

Added by Dominic Cleal over 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Tests
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

I noticed this in the test output from #10941 just after I pushed, but it looks like we have some tests that use Time.now in the expectation and then Time.now (or new) in the tested code, so it's possible for it to run over the second boundary. This results in the following, where the timestamps are slightly different:

unexpected invocation: Proxy::Puppet::PuppetCache.write_to_cache({'./test/fixtures/modules_include' => {'testinclude' => {'timestamp' => 1436970178, 'manifest' => [[#<Proxy::Puppet::PuppetClass:0x4aac8b0>], [#<Proxy::Puppet::PuppetClass:0x4aac5b8>]]}}}, 'example_env')
unsatisfied expectations:
- expected exactly once, not yet invoked: Proxy::Puppet::PuppetCache.write_to_cache({'./test/fixtures/modules_include' => {'testinclude' => {'timestamp' => 1436970177, 'manifest' => [[#<Proxy::Puppet::PuppetClass:0x4abcb48>], [#<Proxy::Puppet::PuppetClass:0x4abca58>]]}}}, 'example_env')

Related issues

Related to Smart Proxy - Bug #10941: puppet classes cache not working rightClosed2015-06-26

Associated revisions

Revision f11f7089 (diff)
Added by Dominic Cleal over 5 years ago

fixes #11131 - use consistent timestamps in cache test expectations

History

#1 Updated by Dominic Cleal over 5 years ago

  • Related to Bug #10941: puppet classes cache not working right added

#2 Updated by The Foreman Bot over 5 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/smart-proxy/pull/302 added
  • Pull request deleted ()

#3 Updated by Dominic Cleal over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Dominic Cleal over 5 years ago

  • Legacy Backlogs Release (now unused) set to 62

#5 Updated by Dominic Cleal over 5 years ago

  • Related to Bug #11229: Import classes does not find any new classes added

#6 Updated by Dominic Cleal over 5 years ago

  • Legacy Backlogs Release (now unused) changed from 62 to 35

Bumping to 1.9 due to regression found.

#7 Updated by Dominic Cleal over 5 years ago

  • Related to deleted (Bug #11229: Import classes does not find any new classes)

Also available in: Atom PDF