Project

General

Profile

Bug #11228

Enabling errata email notification without configuring email server breaks syncs, publishing and promotions

Added by Mike McCune about 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1247387
Description of problem:

Using the web UI, I started editing my user account (admin) and noticing that I had the Email Notification checkbox enabled by default, I proceeded to (still using the web ui) enable several types of email notifications, including errata notification.

Later on, I happened to restart katello-service and my updates to my account were 'picked up'. I then tried to publish a new content view, which failed with an error stating:

"SocketError: getaddrinfo: Name or service not known"

Turns out that, if you start looking into the dynflow task itself, you can see that the real error occurred while trying to send out an email about the errata that this publishing could have made available.

I feel that this is a potential blocker for the user, because, by simply using the web ui and NOT editing /etc/foreman/email.yaml (see http://www.katello.org/docs/2.3/user_guide/email_notifications/index.html) I can render my Satellite completely useless. Since Errata emails are generated every time one syncs a repo or publishes/promotes a content view, the task would error out and the action would never end.

I feel that we should not allow such a thing to happen solely because I changed a configuration using the web ui. Perhaps a warning about emails not being sent should be displayed but the task itself should not fail.

Version-Release number of selected component (if applicable):

  • Satellite 6.1.1 SNAP 14

How reproducible:

Steps to Reproduce:
1. Use the web ui and subscribe the admin user to all available notification emails
2. Create a custom product (or use an existing one) and synchronize it; better yet, use an existing content view and try to publish it
3.

Actual results:

The task fails with an error

Expected results:

Additional info:

Associated revisions

Revision f28b18cc (diff)
Added by Mike McCune about 6 years ago

Fixes #11228 - skip the email step if it fails and warn the user

Revision 6505b7ca
Added by Mike McCune about 6 years ago

Merge pull request #5378 from mccun934/20150727-1522

Fixes #11228 - skip the email step if it fails and warn the user

History

#1 Updated by Mike McCune about 6 years ago

  • Assignee set to Mike McCune
  • Legacy Backlogs Release (now unused) set to 31

#2 Updated by The Foreman Bot about 6 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5378 added
  • Pull request deleted ()

#3 Updated by Anonymous about 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Eric Helms about 6 years ago

  • Triaged changed from No to Yes

Also available in: Atom PDF