Project

General

Profile

Refactor #11280

Revert Ruby 1.8 specifics

Added by Dominic Cleal about 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Hammer core
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Hammer CLI has some workarounds for Ruby 1.8 support, e.g. carrying fastercsv and rb-readline dependencies. These can now be dropped once 1.8 support is gone.


Related issues

Related to Hammer CLI - Refactor #11452: Support rest-client 1.8Closed2015-08-23
Blocked by Hammer CLI - Tracker #8978: Drop Ruby 1.8 support in hammerClosed2015-01-15

Associated revisions

Revision 4dc0ba77 (diff)
Added by Michael Moll about 4 years ago

refs #11280 - drop Ruby 1.8 support

Revision ef61e9a7 (diff)
Added by Michael Moll about 4 years ago

refs #11280 - drop Ruby 1.8 support

Revision 174f507f
Added by Tomas Strachota almost 4 years ago

Merge pull request #176 from mmoll/ruby19

refs #11280 - drop Ruby 1.8 support

Revision 42d61117
Added by Tomas Strachota almost 4 years ago

Merge pull request #188 from mmoll/ruby19

refs #11280 - drop Ruby 1.8 support

History

#1 Updated by Dominic Cleal about 4 years ago

  • Blocked by Tracker #8978: Drop Ruby 1.8 support in hammer added

#2 Updated by The Foreman Bot about 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/hammer-cli/pull/176 added
  • Pull request deleted ()

#3 Updated by Michael Moll almost 4 years ago

#4 Updated by Michael Moll almost 4 years ago

  • Status changed from Ready For Testing to Closed

this is done in current master branches

Also available in: Atom PDF