Project

General

Profile

Bug #11315

Duplicate content view entries are shown in composite content view -> Add page

Added by Walden Raines over 3 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1250716
Description of problem:
Duplicate content view entries are shown in composite content view -> Add page

Version-Release number of selected component (if applicable):
Sat 6.1 GA Snap 15

How reproducible:
Always

Steps to Reproduce:
1. Create a new composite content view using following steps:
2. Navigate to Content -> Content View -> Create New View
3. Enter Name, Check Composite View? checkbox
4. Click Save. This brings the Content Views -> Add tab

Actual results:
Content views are duplicated in this page (see screenshot)

Expected results:
No duplicates in the content views

Additional info:
This happens only during the creation of composite content view. It works fine after creation.

Associated revisions

Revision 494068c7 (diff)
Added by Walden Raines over 3 years ago

Fixes #11315: ensure CVs are only shown once BZ 1250716.

In the composite content view list CVs were being shown multiple
times because we were appending the results of a nutupane.refresh().
This commit ensures the rows will be replaced with the results of the
second call to nutupane.load().

http://projects.theforeman.org/issues/11315
https://bugzilla.redhat.com/show_bug.cgi?id=1250716

Revision 09b46e6c
Added by Walden Raines over 3 years ago

Merge pull request #5408 from waldenraines/11315

Fixes #11315: ensure CVs are only shown once BZ 1250716.

History

#1 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5408 added
  • Pull request deleted ()

#2 Updated by Eric Helms over 3 years ago

  • Legacy Backlogs Release (now unused) set to 70
  • Triaged changed from No to Yes

#3 Updated by Walden Raines over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF