Project

General

Profile

Bug #1139

"Good Host Reports in the last 60 minutes" is always 0% even though puppet is running correctly

Added by monte olvera about 11 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

"Good Host Reports in the last 60 minutes" is always "0/739 hosts (0%)" even though puppet is running correctly. I'm running Foreman 0.3 and have tested it on the nightly release too, same result. This did not happen with foreman-0.2 or previous releases.

The other stats are reporting correctly:
"Hosts that had performed modifications"
"Out Of Sync Hosts"
"Hosts in Error State"
"Hosts With Alerts Disabled"

foreman_good_hosts_issue.bmp View foreman_good_hosts_issue.bmp 3.52 MB monte olvera, 09/01/2011 12:47 PM
reports.bmp View reports.bmp 3.75 MB monte olvera, 09/01/2011 03:01 PM
report_details.bmp View report_details.bmp 3.75 MB monte olvera, 09/01/2011 03:01 PM
puppet_master_syslog.bmp View puppet_master_syslog.bmp 460 KB monte olvera, 09/01/2011 03:01 PM
puppet_client_syslog.bmp View puppet_client_syslog.bmp 377 KB monte olvera, 09/01/2011 03:01 PM
host_report_status.bmp View host_report_status.bmp 3.75 MB monte olvera, 09/01/2011 03:01 PM
server1.domain.com-201109012001.yaml server1.domain.com-201109012001.yaml 4.45 KB monte olvera, 09/01/2011 04:10 PM
server2.domain.com-201109012001.yaml server2.domain.com-201109012001.yaml 4.44 KB monte olvera, 09/01/2011 04:10 PM
server3.domain.com-201109012001.yaml server3.domain.com-201109012001.yaml 4.44 KB monte olvera, 09/01/2011 04:10 PM
foreman-icon-display.bmp View foreman-icon-display.bmp 807 KB monte olvera, 09/06/2011 10:39 AM
Foreman good hosts issue Reports Report details Puppet master syslog Puppet client syslog Host report status Foreman icon display

History

#1 Updated by monte olvera about 11 years ago

the screen shot didn't get uploaded, here it is.

#2 Updated by monte olvera about 11 years ago

ok, disregard the previous update. After restarting my browser I see the file did get uploaded, geez....

#3 Updated by Ohad Levy about 11 years ago

very interesting.. what does the report tab show? does it include any messages etc?

any chance you can provide sample reports?

last question, what version of puppet is running on the host running foreman?

#4 Updated by monte olvera about 11 years ago

see attached. All clients and the puppet/foreman master are running Puppet 2.7.1. I've also tested Puppet 2.7.3 on some clients and a puppet/foreman master in my test environment, same results. I'm running Foreman 0.3 and as previously stated I've tested the nightly version too, same results. Foreman 0.2 was fine and I have not changed anything in Puppet since upgrading to 0.3.

#5 Updated by Ohad Levy about 11 years ago

in order to test it, I would need to get a report yaml file.

can you enable reports = store,.. on your master, it should create some report files and attach them to the ticket?

thanks

#6 Updated by monte olvera about 11 years ago

reports like the ones created here?

/opt/puppet/var/reports/servername.domain.com/201109011957.yaml

If so, see attached. If not please advise.

#7 Updated by monte olvera about 11 years ago

ah, 1 server reported good in the last 60 minutes! How do I find out which server it is? Is there something I can grep for in the yaml report files or an API query I can run?

#8 Updated by monte olvera about 11 years ago

any updates? Thanks.

#9 Updated by Ohad Levy about 11 years ago

any chance the admin user permissions are blocking the operations? do you see anything in foreman logs when a report comes in? using your sample data I cant reproduce the problem.

#10 Updated by Ohad Levy about 11 years ago

  • Status changed from New to Need more information

Ohad Levy wrote:

any chance the admin user permissions are blocking the operations? do you see anything in foreman logs when a report comes in? using your sample data I cant reproduce the problem.

I'm guessing that the Admin user has no more permissions to update hosts... just to be 100% sure, can you try running it with the latest foreman on a clean DB?

#11 Updated by monte olvera about 11 years ago

it's working as expected on the nightly release downloaded this morning (with the same database). Did something change from 09/01/2011's nightly release to 09/06/2011's?

On a side note, the nightly release is not showing the foreman "icon" correctly, see attached.

#12 Updated by Ohad Levy about 11 years ago

  • Status changed from Need more information to Closed

great

I'm guessing you didnt restart your foreman instance or browser cache

#13 Updated by monte olvera about 11 years ago

I restarted apache (foreman and puppet ran from passenger) several times as well as clearing browser cache and restarting my browser. Not sure what's up but glad it's working now. Thanks.

Any thoughts on the foreman icon issue from the previous attachment?

Also available in: Atom PDF