Project

General

Profile

Bug #11410

Unable to delete invalid interfaces from foreman

Added by Jason Frisvold about 6 years ago. Updated about 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I had a few hosts that had overlapping interfaces listed in foreman. Not sure how that happened, presumably on fact imports? Regardless, the interfaces were considered to be invalid according to foreman and should be corrected. Easiest way would be to delete them, but doing so resulted in nothing happening. They re-appeared and changes were not saved.

I was able to resolve this, however. If you change the interface and "correct" the invalid value (name of interface in my case) first, then save, you can go back and delete it later.


Related issues

Is duplicate of Foreman - Bug #11031: Cannot remove interface with duplicate nameClosed2015-07-07

History

#1 Updated by Dominic Cleal about 6 years ago

  • Is duplicate of Bug #11031: Cannot remove interface with duplicate name added

#2 Updated by Dominic Cleal about 6 years ago

  • Status changed from New to Duplicate

Thanks for the report, the issue's being tracked under #11031 and linked tickets.

Also available in: Atom PDF