Project

General

Profile

Bug #11439

Hammer reads local config file named config but should skip it because it isnt a directory

Added by Adam Ruzicka about 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hammer core
Target version:
-
Difficulty:
trivial
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1255086

Description of problem:
Hammer reads a set of config files at start. If in the local directory there is a file called "config" it tries to read it as a hammer config file. However, the hammer documentation stated it should only read config files from a local directory named config, if it is present.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. create local config file with random content
2. hammer shell
3.

Actual results:
error's because it cannot interpret the config file

Expected results:
normal hammer startup where config is ignored

Additional info:


Related issues

Has duplicate Hammer CLI - Bug #15425: hammer doesnt work with a "config" file in pwdDuplicate2016-06-15

Associated revisions

Revision 15d0e048 (diff)
Added by Adam Ruzicka about 4 years ago

Fixes #11439 - Prevents hammer from reading './config' file

Revision d5505366 (diff)
Added by Adam Ruzicka about 4 years ago

Fixes #11439 - Prevents hammer from reading './config' file

Revision c0f8cbfe (diff)
Added by Adam Ruzicka about 4 years ago

Fixes #11439 - Prevents hammer from reading ./config file

Revision cda77ca6
Added by Tomas Strachota almost 4 years ago

Merge pull request #178 from adamruzicka/config-file

Fixes #11439 - Prevents hammer from reading './config' file

History

#1 Updated by The Foreman Bot about 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/hammer-cli/pull/178 added
  • Pull request deleted ()

#2 Updated by Adam Ruzicka almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Dominic Cleal about 3 years ago

  • Has duplicate Bug #15425: hammer doesnt work with a "config" file in pwd added

Also available in: Atom PDF