Project

General

Profile

Feature #1168

Ability to search for Facts (and Param) without providing a value

Added by Bash Shell about 10 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Currently it is not possible to search like so:

hostgroup = X and fact_name = kernelversion

You have to provide a value for kernelversion.

This makes it much harder to get all hosts which have this fact in this hostgroup.

I can search for fact.name=kernelversion on the facts page, but then I lose the ability to filter by hostgroup or parameters.


Related issues

Is duplicate of Foreman - Feature #1611: Search for hosts without certain factsNew2012-05-09

History

#1 Updated by Ohad Levy about 10 years ago

  • Assignee set to Amos Benari

#2 Updated by Tim Speetjens about 10 years ago

One could search for the existence of a fact in the hosts page (with other conditions combined) like so:

hostgroup = X and fact.kernelversion != doesnotexist

Searching that a fact does not exist isn't possible like this though, and I think it would be rather difficult to implement.

#3 Updated by Ohad Levy about 8 years ago

  • Is duplicate of Feature #1611: Search for hosts without certain facts added

#4 Updated by Ohad Levy about 8 years ago

  • Status changed from New to Duplicate

#5 Updated by Ohad Levy about 8 years ago

  • Description updated (diff)
  • Status changed from Duplicate to Need more information

#6 Updated by Ewoud Kohl van Wijngaarden over 7 years ago

  • Status changed from Need more information to Resolved

This should be marked as resolved since you can search for:

hostgroup = X and facts.kernelversion ~ *

If this is insufficient, please re-open.

Also available in: Atom PDF