Project

General

Profile

Refactor #11709

Improve DNS conflict timeout handling

Added by Lukas Zapletal almost 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
DNS
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

We hardcode timeout to three seconds and our message should contain nicer error (at least the resolver server we use).


Related issues

Related to Foreman - Bug #11850: DNS error message assumes two nameserversClosed2015-09-16
Is duplicate of Foreman - Feature #2533: Operation FAILED: NET::ERROR when dns lookups fail. Maybe a more descriptive error?Duplicate2013-05-21

Associated revisions

Revision da5a9c4e (diff)
Added by Lukas Zapletal almost 4 years ago

Fixes #11709 - better error for DNS conflict timeouts

History

#1 Updated by The Foreman Bot almost 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2680 added
  • Pull request deleted ()

#2 Updated by Lukas Zapletal almost 4 years ago

  • Is duplicate of Feature #2533: Operation FAILED: NET::ERROR when dns lookups fail. Maybe a more descriptive error? added

#3 Updated by Dominic Cleal almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 63

#4 Updated by Dominic Cleal almost 4 years ago

  • Related to Bug #11850: DNS error message assumes two nameservers added

#5 Updated by Lukas Zapletal almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF