Project

General

Profile

Bug #11719

can't activate mysql2 (~> 0.3.10), already activated mysql2-0.4.0

Added by Dominic Cleal almost 7 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Database
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

The release of mysql2 0.4.0 is causing a runtime error in MySQL tests - it looks like activerecord is trying to activate ~> 0.3.10, but our Gemfile specifies > 0.3.0.

Our bundler.d/mysql2.rb ought to be updated to match the Rails requirement.

00:04:54.848 Couldn't drop test_plugin_matrix-3-dev : #<LoadError: Please install the mysql2 adapter: `gem install activerecord-mysql2-adapter` (can't activate mysql2 (~> 0.3.10), already activated mysql2-0.4.0. Make sure all dependencies are added to Gemfile.)>

Associated revisions

Revision 47604a20 (diff)
Added by Dominic Cleal almost 7 years ago

fixes #11719 - mysql2 dep must match ActiveRecord's runtime dep

When AR loads the mysql2 adapter, it calls 'gem' with a version spec.
For our bundle to include a compatible version of mysql2 and not the
latest version, the spec needs to match AR's.

Revision 4c206d29 (diff)
Added by Dominic Cleal almost 7 years ago

refs #11719 - change pg/sqlite3 deps to match ActiveRecord

Revision 867876f8 (diff)
Added by Dominic Cleal almost 7 years ago

refs #11719 - match ActiveRecord DB adapter versions

Revision 3a05505b (diff)
Added by Dominic Cleal almost 7 years ago

fixes #11719 - mysql2 dep must match ActiveRecord's runtime dep

When AR loads the mysql2 adapter, it calls 'gem' with a version spec.
For our bundle to include a compatible version of mysql2 and not the
latest version, the spec needs to match AR's.

(cherry picked from commit 47604a20219bdf0f6c72fde9dabd3f47f0513364)

Revision 3eb103a5 (diff)
Added by Dominic Cleal almost 7 years ago

fixes #11719 - mysql2 dep must match ActiveRecord's runtime dep

When AR loads the mysql2 adapter, it calls 'gem' with a version spec.
For our bundle to include a compatible version of mysql2 and not the
latest version, the spec needs to match AR's.

(cherry picked from commit 47604a20219bdf0f6c72fde9dabd3f47f0513364)

Revision fef42ae4 (diff)
Added by Dominic Cleal almost 7 years ago

fixes #11719 - mysql2 dep must match ActiveRecord's runtime dep

When AR loads the mysql2 adapter, it calls 'gem' with a version spec.
For our bundle to include a compatible version of mysql2 and not the
latest version, the spec needs to match AR's.

(cherry picked from commit 47604a20219bdf0f6c72fde9dabd3f47f0513364)

History

#1 Updated by Dominic Cleal almost 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Dominic Cleal

#2 Updated by The Foreman Bot almost 7 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2683 added
  • Pull request deleted ()

#3 Updated by Dominic Cleal almost 7 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF