Project

General

Profile

Feature #11783

Basic ruby 2.0 support on Windows OS

Added by Daniel Helgenberger almost 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
DHCP
Target version:
Difficulty:
trivial
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

On windows, smart-proxy fails to start with more recent ruby versions >=2.0.0 because of the win32/open3 gem requirement

Some people (at least me) have puppet installed on the same host as smart proxy and will need to install ruby 1.9 for smart-proxy only.

Associated revisions

Revision 5f36f2e9 (diff)
Added by Daniel Helgenberger almost 4 years ago

Fixes #11783 - MS providers: add compat for ruby2.0

History

#1 Updated by Dominic Cleal almost 4 years ago

  • Project changed from Foreman to Smart Proxy
  • Category changed from Smart proxies to DHCP
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/smart-proxy/pull/318 added
  • Pull request deleted ()

#2 Updated by Dominic Cleal almost 4 years ago

  • Assignee set to Daniel Helgenberger
  • Legacy Backlogs Release (now unused) set to 63

#3 Updated by Anonymous almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF