Project

General

Profile

Bug #1185

Creating a new hostgroup fails

Added by Jeff Palmer over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

foreman-0.4-0.1rc1.noarch

Installed via the puppet modules (0ae6d7adcff6c6a5904cdd356bce35988de7a419)

I've added one client to a fresh install.
I then try to add a hostgroup and get:

The following error message was observed:
undefined method `domain_id' for #
If you feel this is an error with Foreman itself, please open a new issue with Foreman ticketing system, You would probably need to attach the Full trace and relevant log entries.

undefined method `domain_id' for # ActionView::TemplateError

app/views/common/_domain_subnet.html.erb:2
app/views/hostgroups/_form.html.erb:26
app/views/hostgroups/_form.html.erb:25
app/views/hostgroups/_form.html.erb:14
app/views/hostgroups/_form.html.erb:1
app/views/hostgroups/new.html.erb:3

History

#1 Updated by Ohad Levy over 7 years ago

  • Status changed from New to Feedback
  • Priority changed from Immediate to Normal

I can't reproduce this.

both with and without unattended settings.

when you mean add a host group, is it to add it to the host, or create a new host group?

#2 Updated by Jeff Palmer over 7 years ago

  • Status changed from Feedback to Closed

After reinstalling foreman 0.4rc1, this issue is not re-occuring. Closing the ticket.

Also available in: Atom PDF