Project

General

Profile

Bug #11884

Turbolinks load some pages twice

Added by Lukas Zapletal about 5 years ago. Updated 11 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

This is very annoing and happens all the time with Discovered Hosts page, but I am able to reproduce with other pages. First, make sure you have some Facts records uploaded in your database prior testing this.

1) Open browser HTTP debug window or similar
2) Click on Monitor -> Dashboard
3) Click on Monitor -> Fact Values
4) Click on Monitor -> Dashboard
5) Note that /dashboard HTTP 200 was sent twice.

I noticed that this happens usually the request after page was reloaded. I am not sure what is the key here to reload pages

With discovered hosts, this happens all the time


Related issues

Related to Discovery - Bug #11837: Serching for "facts.blah" in discovery takes a long timeClosed2015-09-15
Related to Foreman - Task #23449: replace turbolinks with SPA approach to load partial html contentNew
Is duplicate of Foreman - Bug #12772: Web UI seems to make double calls to Foreman Passenger App in 1.10-rc3Duplicate2015-12-10

History

#1 Updated by Lukas Zapletal about 5 years ago

  • Related to Bug #11837: Serching for "facts.blah" in discovery takes a long time added

#2 Updated by Lukas Zapletal about 5 years ago

  • Description updated (diff)

#3 Updated by Lukas Zapletal about 5 years ago

Idea: Maybe the turbolink JS is inserted twice on some pages.

#4 Updated by Dominic Cleal about 5 years ago

That's normal behaviour when the assets change between pages. If the assets are different then it can't reload the new page within the old one and instead has to do a full page load.

It's only an issue when the JavaScript between pages is different, as CSS is app-wide. There are a bunch of pages with their own specific JS additions, like the dashboard and hosts pages, but many other pages that you get the benefit on.

#5 Updated by Ohad Levy over 2 years ago

  • Is duplicate of Bug #12772: Web UI seems to make double calls to Foreman Passenger App in 1.10-rc3 added

#6 Updated by Ohad Levy over 2 years ago

  • Status changed from New to Duplicate

#7 Updated by Ohad Levy over 2 years ago

  • Related to Task #23449: replace turbolinks with SPA approach to load partial html content added

#8 Updated by Ian Ballou 11 months ago

Is this bug something that can be fixed or would the effort be too great? Another bug (#27175) was filed more recently about the same issue. I see this issue and its duplicate haven't been resolved yet. Sounds like this might be a side effect of Turbolinks?

Also available in: Atom PDF