Project

General

Profile

Bug #11962

Override of Host-Parameter is saved malformed

Added by Manuel Ambauen over 6 years ago. Updated over 6 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Parameters
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When I edit a host with an existing parameter override and save it, I get:

"[\"192.168.1.1\",\"192.168.1.10\"]"
Before update to Foreman 1.9.2 saved value was:
["192.168.1.1","192.168.1.10"]

When I submit the host a second time:
"\"[\\\"192.168.1.1\\\",\\\"192.168.1.10\\\"]\""

I saw that this only happens when I try to save an array or a hash.


Related issues

Is duplicate of Foreman - Bug #11375: Smart class parameters turn YAML to string when using a multi line yamlClosed2015-08-16

History

#1 Updated by Dominic Cleal over 6 years ago

  • Is duplicate of Bug #11375: Smart class parameters turn YAML to string when using a multi line yaml added

#2 Updated by Dominic Cleal over 6 years ago

  • Status changed from New to Duplicate

Thanks for the report. This is another side effect of issue #11375, which I'm fixing at the moment.

#3 Updated by Manuel Ambauen over 6 years ago

Dominic Cleal wrote:

Thanks for the report. This is another side effect of issue #11375, which I'm fixing at the moment.

I'm sorry. Didn't see the other ticket. Thanks for your great work! :-)

Also available in: Atom PDF