Project

General

Profile

Bug #11968

hammer respository-set command name mismatch

Added by Brad Buckingham over 3 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
API
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1235823
Description of problem:

The name of the repository set passed via hammer and the name displayed by hammer are different (arch & release are appended):

  1. hammer repository-set available-repositories --product "Red Hat Enterprise Linux Server" --name "Red Hat Enterprise Linux 6 Server (RPMs)" --organization-id 3
    ------------------------------------------------------|--------|---------|--------
    NAME | ARCH | RELEASE | ENABLED
    ------------------------------------------------------|--------|---------|--------
    Red Hat Enterprise Linux 6 Server RPMs i386 6.1 | i386 | 6.1 | no
    Red Hat Enterprise Linux 6 Server RPMs x86_64 6.1 | x86_64 | 6.1 | no
    Red Hat Enterprise Linux 6 Server RPMs i386 6.2 | i386 | 6.2 | no
    Red Hat Enterprise Linux 6 Server RPMs x86_64 6.2 | x86_64 | 6.2 | no
    Red Hat Enterprise Linux 6 Server RPMs i386 6.3 | i386 | 6.3 | no
    Red Hat Enterprise Linux 6 Server RPMs x86_64 6.3 | x86_64 | 6.3 | no
    Red Hat Enterprise Linux 6 Server RPMs i386 6.4 | i386 | 6.4 | no
    Red Hat Enterprise Linux 6 Server RPMs x86_64 6.4 | x86_64 | 6.4 | no
    Red Hat Enterprise Linux 6 Server RPMs i386 6.5 | i386 | 6.5 | no
    Red Hat Enterprise Linux 6 Server RPMs x86_64 6.5 | x86_64 | 6.5 | no
    Red Hat Enterprise Linux 6 Server RPMs i386 6.6 | i386 | 6.6 | no
    Red Hat Enterprise Linux 6 Server RPMs x86_64 6.6 | x86_64 | 6.6 | no
    Red Hat Enterprise Linux 6 Server RPMs i386 6Server | i386 | 6Server | no
    Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server | x86_64 | 6Server | yes
    ------------------------------------------------------|--------|---------|--------

The name displayed should be 'Red Hat Enterprise Linux 6 Server RPMs' arch and release information are in their respective columns.

Version-Release number of selected component (if applicable):
6.1 public beta.

How reproducible:
Always,

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Associated revisions

Revision db1c4c35 (diff)
Added by Brad Buckingham over 3 years ago

fixes #11968: add content name to repository information returned

Currently, when a user invokes the 'repository-set available-repositories'
command, the 'name' field is displayed simmilar to the following:
Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server

The above includes the architecture and release version; however, that
information is also returned as separate attributes. Since the name
can be used for operations such as enable, disable, info, it would
be better to return the name similar to the following:
Red Hat Enterprise Linux 6 Server (RPMs)

This commit displays the 'name' vs the 'repo_name' attribute returned.

Revision 9217a2bb (diff)
Added by Brad Buckingham over 3 years ago

refs #11968: add content name to repository information returned

Currently, when a user invokes the API (or CLI) for 'available-repositories'
the repo_name returned is similar to:
Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server

The above includes the architecture and release version; however, that
information is also returned as separate attributes. Since the name
can be used for operations such as enable, disable, info, it would
be better to return the name similar to the following:
Red Hat Enterprise Linux 6 Server (RPMs)

This commit adds a 'name' to the information returned.

Revision a52bf9c0
Added by Brad Buckingham over 3 years ago

Merge pull request #5499 from bbuckingham/issue-11968

refs #11968: add content name to repository information returned

Revision bc3c3bdd
Added by Brad Buckingham over 3 years ago

Merge pull request #322 from bbuckingham/issue-11968

fixes #11968: add content name to repository information returned

History

#1 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5499 added
  • Pull request deleted ()

#2 Updated by Eric Helms over 3 years ago

  • Category set to API
  • Legacy Backlogs Release (now unused) set to 70
  • Triaged changed from No to Yes

#3 Updated by Brad Buckingham over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF