Project

General

Profile

Bug #12047

Passenger fails to load on RHEL 6.7

Added by Mike McCune almost 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Installer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1268420
Description of problem:

Installing Satellite 6.1.3 (Satellite-6.1.0-RHEL-6-20151002.0 compose) onto a RHEL 6.7 x86_64 system succeeds but once you try to access it via the web ui you get an error:

uninitialized constant ActiveModel::ForbiddenAttributesProtection (NameError)

I also noticed that qpidd is dead (see further down)

Version-Release number of selected component (if applicable):

  • apr-util-ldap-1.3.9-3.el6_0.1.x86_64
  • candlepin-0.9.49.8-1.el6.noarch
  • candlepin-common-1.0.22-1.el6.noarch
  • candlepin-scl-1-5.el6_4.noarch
  • candlepin-scl-quartz-2.1.5-5.el6_4.noarch
  • candlepin-scl-rhino-1.7R3-1.el6_4.noarch
  • candlepin-scl-runtime-1-5.el6_4.noarch
  • candlepin-selinux-0.9.49.8-1.el6.noarch
  • candlepin-tomcat6-0.9.49.8-1.el6.noarch
  • elasticsearch-0.90.10-7.el6.noarch
  • foreman-1.7.2.40-1.el6_6sat.noarch
  • foreman-compute-1.7.2.40-1.el6_6sat.noarch
  • foreman-debug-1.7.2.40-1.el6_6sat.noarch
  • foreman-gce-1.7.2.40-1.el6_6sat.noarch
  • foreman-libvirt-1.7.2.40-1.el6_6sat.noarch
  • foreman-ovirt-1.7.2.40-1.el6_6sat.noarch
  • foreman-postgresql-1.7.2.40-1.el6_6sat.noarch
  • foreman-proxy-1.7.2.6-1.el6.noarch
  • foreman-selinux-1.7.2.13-1.el6_6sat.noarch
  • foreman-vmware-1.7.2.40-1.el6_6sat.noarch
  • katello-2.2.0.16-1.el6_6sat.noarch
  • katello-certs-tools-2.2.1-1.el6_6sat.noarch
  • katello-common-2.2.0.16-1.el6_6sat.noarch
  • katello-debug-2.2.0.16-1.el6_6sat.noarch
  • katello-default-ca-1.0-1.noarch
  • katello-installer-2.3.20-1.el6.noarch
  • katello-installer-base-2.3.20-1.el6.noarch
  • katello-server-ca-1.0-1.noarch
  • katello-service-2.2.0.16-1.el6_6sat.noarch
  • openldap-2.4.40-5.el6.x86_64
  • pulp-docker-plugins-0.2.5-1.el6_6sat.noarch
  • pulp-katello-0.5-1.el6_6sat.noarch
  • pulp-nodes-common-2.6.0.16-1.el6.noarch
  • pulp-nodes-parent-2.6.0.16-1.el6.noarch
  • pulp-puppet-plugins-2.6.0.16-1.el6.noarch
  • pulp-puppet-tools-2.6.0.16-1.el6.noarch
  • pulp-rpm-plugins-2.6.0.16-1.el6.noarch
  • pulp-selinux-2.6.0.16-1.el6.noarch
  • pulp-server-2.6.0.16-1.el6.noarch
  • python-ldap-2.3.10-1.el6.x86_64
  • ruby193-rubygem-ldap_fluff-0.3.2-1.el6_6sat.noarch
  • ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
  • ruby193-rubygem-runcible-1.3.5-1.el6_6sat.noarch
  • rubygem-hammer_cli-0.1.4.12-1.el6_6sat.noarch
  • rubygem-hammer_cli_foreman-0.1.4.14-1.el6_6sat.noarch
  • rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el6_6sat.noarch
  • rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el6_6sat.noarch
  • rubygem-hammer_cli_foreman_docker-0.0.3.9-1.el6_6sat.noarch
  • rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el6_6sat.noarch
  • rubygem-hammer_cli_gutterball-0.0.1.3-1.el6_6sat.noarch
  • rubygem-hammer_cli_import-0.10.20-1.el6_6sat.noarch
  • rubygem-hammer_cli_katello-0.0.7.17-1.el6_6sat.noarch
  • sssd-ldap-1.12.4-47.el6.x86_64

How reproducible:

Steps to Reproduce:
1. Install the Satellite-6.1.0-RHEL-6-20151002.0 compose onto a RHEL 6.7 x86_64 system
2. Try to log in via the web ui
3.

Actual results:

Expected results:

Additional info:

  1. katello-service status
    mongod (pid 14824) is running...
    listening on 127.0.0.1:27017
    connection test successful

qdrouterd (pid 16906) is running...
celery init v10.0.
Using config script: /etc/default/pulp_workers
node reserved_resource_worker-0 (pid 15577) is running...
node reserved_resource_worker-1 (pid 15600) is running...
node reserved_resource_worker-2 (pid 15629) is running...
node reserved_resource_worker-3 (pid 15658) is running...
celery init v10.0.
Using config script: /etc/default/pulp_resource_manager
node resource_manager (pid 15419) is running...
celery init v10.0.
Using configuration: /etc/default/pulp_workers, /etc/default/pulp_celerybeat
pulp_celerybeat (pid 15734) is running.
foreman-proxy (pid 16847) is running...
elasticsearch (pid 15787) is running...
tomcat6 (pid 15188) is running... [ OK ]
dynflow_executor is running.
dynflow_executor_monitor is running.
httpd (pid 16751) is running...
Some services failed: qpidd

Associated revisions

Revision db486f1b (diff)
Added by Mike McCune almost 4 years ago

Fixes #12047 - force loading of the strong_parameters gem

Revision 879bc679
Added by Mike McCune almost 4 years ago

Merge pull request #5509 from mccun934/20151002-1333

Fixes #12047 - force loading of the strong_parameters gem

History

#1 Updated by Mike McCune almost 4 years ago

  • Subject changed from Satellite system installs but cannot be used due to service errors on RHEL 6.7 to Passenger fails to load on RHEL 6.7

#2 Updated by The Foreman Bot almost 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5509 added
  • Pull request deleted ()

#3 Updated by Anonymous almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Eric Helms almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 70
  • Triaged changed from No to Yes

Also available in: Atom PDF