Project

General

Profile

Bug #12074

rack-cache 1.3.0 is incompatible with Ruby 1.9.3

Added by Eric Helms almost 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Packaging
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

During bundle install:

Installing rack-cache 1.3.0

Gem::InstallError: rack-cache requires Ruby version >= 2.0.0.

Related issues

Related to Foreman - Refactor #8884: Drop Ruby 1.9.3 supportClosed2015-01-09

Associated revisions

Revision 3b3f0a11 (diff)
Added by Eric Helms almost 4 years ago

Fixes #12074: Pin rack-cache to less than 1.3.0

The 1.3.0 version of rack-cache requires Ruby 2.0 or greater.

Revision 9399b0a6 (diff)
Added by Eric Helms almost 4 years ago

Fixes #12074: Pin rack-cache to less than 1.3.0

The 1.3.0 version of rack-cache requires Ruby 2.0 or greater.

(cherry picked from commit 3b3f0a118c9ec860abf52b454e8d70c9132e8948)

Revision 24436512 (diff)
Added by Eric Helms almost 4 years ago

Fixes #12074: Pin rack-cache to less than 1.3.0

The 1.3.0 version of rack-cache requires Ruby 2.0 or greater.

(cherry picked from commit 3b3f0a118c9ec860abf52b454e8d70c9132e8948)

History

#1 Updated by The Foreman Bot almost 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2786 added
  • Pull request deleted ()

#2 Updated by Michael Moll almost 4 years ago

#3 Updated by Dominic Cleal almost 4 years ago

  • Category set to Packaging
  • Assignee set to Eric Helms
  • Legacy Backlogs Release (now unused) set to 91

#4 Updated by Eric Helms almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF