Project

General

Profile

Feature #12093

In Smart Class Parameter, The array elements should be validated with validator type 'list'.

Added by Bryan Kearney almost 7 years ago. Updated over 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Parameters
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1269398
Description of problem:
In smart class Parameters, The array elements of key type array should be validated with Validator Type 'list'.
As of now the array key type is not validated with validator type 'list'.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Override the default value of smart class parameter.
2. Select Key type array.
3. Provide the array of elements as new Default Value.
4. Select validator type as list.
5. Validator rule should have each element in array of step 3.

Actual results:

Expected results:
On Submit, the change is successfully accepted as all the elements in array are present in validator rules list.
If at least one element of array is not present in validator rules list, then It should allow to accept this change and should display the as 'element in not one of list'.

Additional info:


Related issues

Is duplicate of Foreman - Feature #12081: In Smart Class Parameter, The array elements should be validated with validator type 'list'.New2015-10-07

History

#1 Updated by Bryan Kearney almost 7 years ago

  • Category set to Parameters

#2 Updated by Dominic Cleal over 6 years ago

  • Is duplicate of Feature #12081: In Smart Class Parameter, The array elements should be validated with validator type 'list'. added

#3 Updated by Dominic Cleal over 6 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF