Project

General

Profile

Actions

Bug #1221

closed

Bug with server.next-server in DHCP

Added by Ashley Penney over 12 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

Hey Ohad,

Ever since I upgraded to the latest git head I've been having an issue with the proxy putting in the wrong next-server entry:

supersede server.filename = "pxelinux.0";
supersede server.next-server = 0a:2d:03:65;
supersede host-name = "cosmos2";

broken ones get:

supersede server.filename = "pxelinux.0";
supersede server.next-server = 0a:2d:03:42;
supersede host-name = "brokenhost";

Looking at this closer I know what the issue is but not why - when my puppetserver booted it dhcped to the wrong address (.66, aka :42) and then I manually re-iped it to .101 (aka :65). I have restarted the proxy but it's like it has cached somewhere that the puppet server is on .66 still and is not adapting to the real ip of 101.

Actions #1

Updated by Ohad Levy about 12 years ago

did you figure this one out?

my guess is that somewhere (etc/hosts, nscd etc) keeps a cache

Actions #2

Updated by Ohad Levy about 12 years ago

  • Status changed from New to Feedback
Actions #3

Updated by Ohad Levy over 11 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF