Project

General

Profile

Bug #12225

TopbarSweeper should invalidate on plugin installation/removal

Added by Lukas Zapletal about 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Plugin integration
Target version:

Description

Users (and devs apparently) forget to log-out missing items in the main menu :)


Related issues

Related to Website - Feature #14670: Inform somewhere that after adding plugin user should logout/login to see it in WebUINew2016-04-15
Related to Foreman - Bug #15040: Could not find table 'users' during db:migrateClosed2016-05-13
Related to Foreman - Bug #10802: relation "users" does not exist present when migratingClosed2015-06-12

Associated revisions

Revision c3e0fed1 (diff)
Added by Lukas Zapletal over 4 years ago

Fixes #12225 - invalidate topbar cache after restart

History

#1 Updated by The Foreman Bot about 5 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2849 added
  • Pull request deleted ()

#2 Updated by Dominic Cleal almost 5 years ago

  • Related to Feature #14670: Inform somewhere that after adding plugin user should logout/login to see it in WebUI added

#3 Updated by Dominic Cleal over 4 years ago

  • Category changed from Web Interface to Plugin integration
  • Status changed from Ready For Testing to New
  • Assignee deleted (Lukas Zapletal)

PR closed.

#4 Updated by Lukas Zapletal over 4 years ago

  • Status changed from New to Rejected

Since we upgraded to Rails 4.x this patch is no longer necessary and it just works. Compare

http://edgeguides.rubyonrails.org/caching_with_rails.html#fragment-caching

with

http://guides.rubyonrails.org/v3.2/caching_with_rails.html#fragment-caching

(search for md5)

#5 Updated by Dominic Cleal over 4 years ago

  • Status changed from Rejected to New

Re-opening as the issue is still present, tested on current develop. As per my comment at https://github.com/theforeman/foreman/pull/2849#issuecomment-217127785, the view fragment isn't changed when installing/uninstalling plugins, so the cache wouldn't get invalidated by the new mechanism in Rails 4. The digest is disabled in any case.

#6 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Lukas Zapletal
  • Pull request https://github.com/theforeman/foreman/pull/3496 added

#7 Updated by The Foreman Bot over 4 years ago

  • Pull request https://github.com/theforeman/foreman/pull/3517 added

#8 Updated by Lukas Zapletal over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#9 Updated by Dominic Cleal over 4 years ago

  • Related to Bug #15040: Could not find table 'users' during db:migrate added

#10 Updated by Dominic Cleal over 4 years ago

  • Legacy Backlogs Release (now unused) set to 136

#11 Updated by Dominic Cleal over 4 years ago

  • Related to Bug #10802: relation "users" does not exist present when migrating added

Also available in: Atom PDF