Project

General

Profile

Feature #12293

Control the attributes which are returned from a list command

Added by Bryan Kearney almost 3 years ago. Updated about 1 month ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Hammer core
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Marek
Fixed in Releases:
Found in Releases:

Description

Users would like to pass in a set of attributes for an object, and use that control the output of the list commands. For example

hammer foo list --attribtues A,B,C,D --csv

would return

A,B,C,D
foo1.A, foo1.B, foo1.C, foo1.D
foo2.A, foo2.B, foo2.C, foo2.D


Related issues

Related to Foreman - Feature #16314: Generate a custom report of specific fieldsDuplicate2016-08-26
Is duplicate of Hammer CLI - Feature #19135: Possibility to limit or add fields that are displayedReady For Testing

History

#1 Updated by Bryan Kearney almost 3 years ago

  • Bugzilla link set to 1267445

#2 Updated by Ondřej Pražák about 2 years ago

  • Related to Feature #16314: Generate a custom report of specific fields added

#3 Updated by Tomáš Strachota almost 2 years ago

  • Subject changed from [RFE] Control the attributes which are returned from a list command to Control the attributes which are returned from a list command
  • Category set to Hammer core
  • Target version set to 115

#4 Updated by Thomas McKay almost 2 years ago

@marek - I would suggest moving this to hammer csv category. I have this working already for content-hosts (which could also dump out custom host info too, of course). If you're agreeable, assign to me and switch category. Thanks!

#5 Updated by Tomáš Strachota almost 2 years ago

Hi Tom, it's great you have it working in csv already. I vote for keeping the issue in hammer core and implement it in generic manner so that other output adapters can use it and all plugins can take advantage of optional columns. Hopefully it will be possible to re-use code from your solution.

#6 Updated by Akshay Mendhe about 1 month ago

  • Triaged set to No
  • Assignee set to Akshay Mendhe

#7 Updated by Tomáš Strachota about 1 month ago

  • Status changed from New to Duplicate

Hi Akshay,
I'm sorry but this issue is a duplicate of https://projects.theforeman.org/issues/19135 that we already have an open PR for. I didn't realize this issue exist until you assigned it to yourself and I received a notification. I'm going to close this one in favor of 19135.

#8 Updated by Tomáš Strachota about 1 month ago

  • Is duplicate of Feature #19135: Possibility to limit or add fields that are displayed added

Also available in: Atom PDF