Project

General

Profile

Bug #12300

Version 1.8 from docker-engine breaks Function on Foreman 1.9.2

Added by Christian Ehart over 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Version 1.8 from docker-engine breaks Function on Foreman 1.9.2

Version-Release number of selected component (if applicable):
docker-engine-1.8.x
pulp-docker-plugins-1.0.1-1.el7.noarch
python-pulp-docker-common-1.0.1-1.el7.noarch
ruby193-rubygem-docker-api-1.17.0-1.el7.noarch
ruby193-rubygem-foreman_docker-1.4.1-1.fm1_9.el7.noarch
rubygem-hammer_cli_foreman_docker-0.0.3-2.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. install docker-engine 1.8.x
2. docker pull katello.cesystems.at:5000/cesystems-docker_images-cirros
3. create Container over Katello GUI

Actual results:
for step2: Tag latest not found in repository katello.cesystems.at:5000/cesystems-docker_images-cirros
for step3: Error "undefined method `full_messages' for []:Array"

Root Cause:
It looks like Docker added a header, look at the GET REPO Command, see attachment "docker-engine-1.x.log"
1.7.x: "GET /v1/repositories/library/cesystems-docker_images-cirros/tags HTTP/1.1" 200 232 "-"
1.8.x: "GET /v1/repositories/library/cesystems-docker_images-cirros/tags/latest HTTP/1.1" 404 233 "-

Additional info:
with docker-engine 1.7.x and lower version everything is fine
see original request under https://groups.google.com/forum/#!topic/foreman-users/48ePbihsI-w

production.log production.log 26.1 KB Christian Ehart, 10/23/2015 04:19 PM
Trace.txt Trace.txt 12.1 KB Christian Ehart, 10/23/2015 04:19 PM
docker-engine-1.7.x.log docker-engine-1.7.x.log 4.22 KB Christian Ehart, 10/23/2015 04:19 PM
docker-engine-1.8.x.log docker-engine-1.8.x.log 1.08 KB Christian Ehart, 10/23/2015 04:20 PM

Related issues

Related to Katello - Bug #13640: When will katello ship with #12300 solved...?Rejected2016-02-10

History

#1 Updated by Arno Schoenmakers over 6 years ago

  • Related to Bug #13640: When will katello ship with #12300 solved...? added

#2 Updated by Justin Sherrill almost 6 years ago

  • Project changed from Docker to Katello
  • Category deleted (Plugin (foreman_docker))
  • Status changed from New to Rejected
  • Legacy Backlogs Release (now unused) set to 166

This looks like a crane issue.

With Katello 3.0 we migrated to Dockerv2 and haven't seen this issue.

I'll go ahead and close this, please reopen if you can reproduce. Thanks!

Also available in: Atom PDF