Project

General

Profile

Bug #12349

Filtering host groups does not work in the host creation screen

Added by Thomas Saquet about 5 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Users, Roles and Permissions
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hello,

I think I may have a problem related to host groups filtering:

I can limit the displayed host groups by filtering on the group name, it works on the host groups screen.
Though, when I create a host, I can choose among all the existing host groups in the drop down menu. I think I should not be able to see those. Did I miss something ?

It may be related to http://projects.theforeman.org/issues/10923.

Thank you :)


Related issues

Is duplicate of Foreman - Feature #7289: ACL who can add a host to hostgroup.New2014-08-28

History

#1 Updated by Dominic Cleal about 5 years ago

  • Is duplicate of Feature #7289: ACL who can add a host to hostgroup. added

#2 Updated by Dominic Cleal about 5 years ago

  • Status changed from New to Duplicate

Thanks for the report. I think we're tracking this already under #7289 and some of the linked issues, there are a lot of problems with authorisation to associated resources and I think it covers hosts to host groups.

#3 Updated by Thomas Saquet about 5 years ago

Thank you ! I didn't search in issues older than 1 year :/ About it, I can see that the previous demand is dated from about one year ago, do you think these problems will be addressed soon ? I am working on Foreman integration in a continuous integration tool chain and this may be a problem for me about data partitioning between users.

Thank you in advance.

#4 Updated by Dominic Cleal about 5 years ago

I think it's unlikely to be addressed soon, I've not seen any work on it lately. The organisations/locations feature should apply to the host group selection, but it's a lot more complex to use IMHO - you may want to try it out.

Also available in: Atom PDF