Project

General

Profile

Bug #12391

Discovery breaks ignore_puppet_facts_for_provisioning global setting

Added by Matt Jarvis over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
High
Category:
Discovery plugin
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

For the last couple of versions of Foreman, the disabling of auto-creation of network interfaces has stopped working. This used to be disabled by setting ignore puppet facts for provisioning to True, which we have set, but we still get network interfaces being created. This is a big problem for us on OpenStack compute nodes, which have many virtual interfaces created, and eventually this ends up with timeouts in puppet and Foreman as there can be many hundreds of interfaces for a host, which also stops us being able to edit the host. The only fix is to delete them all via the API.


Related issues

Related to Foreman - Feature #9104: Disable auto network interfacesClosed2015-01-25
Related to Foreman - Feature #11972: Implement regex for option ignore_puppet_facts_for_provisioningClosed2015-09-26
Related to Foreman - Bug #11047: Interfaces are imported even though ignore_puppet_facts_for_provisioning is set to trueResolved2015-07-08
Related to Discovery - Bug #14643: Migration broken with discovered hostsClosed2016-04-14

Associated revisions

Revision 94474795 (diff)
Added by Lukas Zapletal over 3 years ago

Fixes #12391 - introduced foreman_discovery fact parser

History

#1 Updated by Dominic Cleal over 3 years ago

  • Related to Feature #9104: Disable auto network interfaces added

#2 Updated by Dominic Cleal over 3 years ago

  • Category set to Importers

#3 Updated by Matt Jarvis over 3 years ago

In poking around in the facts importer in the codebase I spotted this commit https://github.com/theforeman/foreman/commit/379de99adbde93349824d4516b95079bfd970e90
which would partially solve the problem for us. In the meantime I've locally patched our copy to exclude the qbr|qvo|ovs|tap etc interfaces that OpenStack uses which seems to be stopping them being created.

#4 Updated by Brandon Weeks over 3 years ago

+1 I can reproduce this.

#5 Updated by Brandon Weeks over 3 years ago

+1 I can reproduce this.

Both ignore_puppet_facts_for_provisioning and #11972 are happening "too late." The fact_name table spam is unaffected by their use. ignore_puppet_facts_for_provisioning doesn't even seem to prevent the nics table entries from being created.

#6 Updated by Brandon Weeks over 3 years ago

Brandon Weeks wrote:

+1 I can reproduce this.

Both ignore_puppet_facts_for_provisioning and #11972 are happening "too late." The fact_name table spam is unaffected by their use. ignore_puppet_facts_for_provisioning doesn't even seem to prevent the nics table entries from being created.

https://github.com/theforeman/foreman_discovery/blob/develop/app/lib/puppet_fact_parser_extensions.rb#L25

Well that's definitely the cause.

#7 Updated by Dominic Cleal over 3 years ago

  • Project changed from Foreman to Discovery
  • Category changed from Importers to Discovery plugin

Ouch, that's pretty special. I'll punt this to the Discovery plugin for now then, hopefully Matt will confirm that he's got that installed too.

#8 Updated by Matt Jarvis over 3 years ago

Yes, we've got the Discovery plugin installed.

#9 Updated by Brandon Weeks over 3 years ago

  • Related to Feature #11972: Implement regex for option ignore_puppet_facts_for_provisioning added

#10 Updated by Brandon Weeks over 3 years ago

Thank for spotting that commit Matt, it has been a huge help for us. I've proposed backporting in #11972.

#11 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #11047: Interfaces are imported even though ignore_puppet_facts_for_provisioning is set to true added

#12 Updated by Lukas Zapletal over 3 years ago

  • Subject changed from Disable auto creation of network interfaces not working to Discovery breaks ignore_puppet_facts_for_provisioning global setting
  • Status changed from New to Assigned
  • Assignee set to Lukas Zapletal

Yeah a bummer, did not realize this actually affect everything.

#13 Updated by The Foreman Bot over 3 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_discovery/pull/234 added

#14 Updated by Lukas Zapletal over 3 years ago

Matt, can you try this patch if it helps? https://github.com/theforeman/foreman_discovery/pull/234

#15 Updated by Anonymous over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#16 Updated by Lukas Zapletal over 3 years ago

  • Bugzilla link set to 1313675

#17 Updated by Lukas Zapletal over 3 years ago

  • Related to Bug #14643: Migration broken with discovered hosts added

Also available in: Atom PDF