Project

General

Profile

Bug #12465

ISC DHCP proxy fails to parse deleted entires

Added by Brandon Weeks about 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
DHCP
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

In /var/lib/dhcpd/dhcpd.leases the following type of entry may appear:

host test.example.com {
dynamic;
deleted;
}

in /var/log/foreman-proxy/proxy.log the follow error occurs:

W, [2015-11-13T02:54:47.675517 #31861] WARN -- : skipped test.example.com - address family must be specified

Trackback attached.

proxy_traceback.txt proxy_traceback.txt 4.17 KB Brandon Weeks, 11/13/2015 03:32 AM

Related issues

Related to Smart Proxy - Refactor #11866: Replace linear searches in various lookups in DHCP module with constant-time lookups.Closed2015-09-17
Related to Smart Proxy - Bug #12469: ISC DHCP proxy errors when attempting to delete nonexistant recordsClosed2015-11-13

Associated revisions

Revision d981fe9f (diff)
Added by Brandon Weeks about 4 years ago

Fixes #12465 - remove deleted records from results

History

#1 Updated by Dominic Cleal about 4 years ago

  • Project changed from Foreman to Smart Proxy
  • Category changed from Smart Proxy to DHCP
  • Legacy Backlogs Release (now unused) set to 63

Looks like a regression to me, the parse_config_and_leases_for_records method shouldn't be performing a subnet lookup by IP as it won't be present.

#2 Updated by Dominic Cleal about 4 years ago

  • Related to Refactor #11866: Replace linear searches in various lookups in DHCP module with constant-time lookups. added

#3 Updated by The Foreman Bot about 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/smart-proxy/pull/338 added

#4 Updated by Dominic Cleal about 4 years ago

  • Related to Bug #12469: ISC DHCP proxy errors when attempting to delete nonexistant records added

#5 Updated by The Foreman Bot about 4 years ago

  • Assignee set to Brandon Weeks

#6 Updated by Brandon Weeks about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF