Project

General

Profile

Bug #12483

Activation Keys not loaded after UPG from 2.3.1 to 2.4.0RC2

Added by Christian Ehart over 3 years ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Activation Key
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Issue1: Activation_Key Page is not loaded by clicking "Content => Activation Keys"
Issue2: Hostgroup displays error for Activation_Keys "Error while loading activation keys from Katello"

activation-key_production.log activation-key_production.log 26.6 KB Christian Ehart, 11/15/2015 03:18 AM
host-group__production.log host-group__production.log 126 KB Christian Ehart, 11/15/2015 03:18 AM
workaround.log workaround.log 32.7 KB Christian Ehart, 11/15/2015 02:21 PM

Related issues

Related to Katello - Bug #12510: 2.4.0 upgrade does not have new content indexedClosed2015-11-17

History

#1 Updated by Christian Ehart over 3 years ago

Its strange, but I found out that the problem gets somehow fixed by itself if you create a "dummy product" by clicking "Content => Products => New Product".

Afterwards you can now access the "Activation_Key Page" whithout any issue and also Keys are loaded under Host Group Page. All works well also if you delete now the so called "dummy product"...

Attached also the logs for this scenario, hope it helps to find the Root Cause..

#2 Updated by Justin Sherrill over 3 years ago

I did confirm that this is caused by the same cause as http://projects.theforeman.org/issues/12510

but instead of content, its subscriptions that aren't being indexed, the fix solves both though.

#3 Updated by Justin Sherrill over 3 years ago

This was resolved in RC2 in the associated issue.

#4 Updated by Justin Sherrill over 3 years ago

  • Related to Bug #12510: 2.4.0 upgrade does not have new content indexed added

#5 Updated by Justin Sherrill over 3 years ago

  • Status changed from New to Resolved

#6 Updated by Eric Helms over 3 years ago

  • Triaged changed from No to Yes

Also available in: Atom PDF