Project

General

Profile

Bug #12525

exit code when enabling repository-set changed, message is not that helpful as well

Added by Brad Buckingham almost 5 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Category:
API
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1249655
Description of problem:
Exit code when enabling repository-set changed, message is not that helpful as well

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150721.7-Satellite-x86_64
vs.
Satellite-6.1.0-RHEL-6-20150731.1-Satellite-x86_64

How reproducible:
always

Steps to Reproduce:
1. Attempt to enable repository-set without providing all the substitutions: # hammer --username <user> --password <pass> repository-set enable \
--product-id 6 --id 1952

Actual results:
  1. hammer --username admin --password changeme repository-set enable --product-id 6 --id 1952
    Could not enable repository: {} are not valid substitutions for /content/dist/rhel/server/6/$releasever/$basearch/kickstart
  2. echo $?
    65

Expected results:
Error message from hammer from the older compose seems to be more helpful to me:

  1. hammer --username admin --password changeme repository-set enable --product-id 6 --id 1952
    Could not enable repository:
    Missing arguments for 'basearch', 'releasever'
  2. echo $?
    64

Additional info:
Please feel free to close as notabug. I just want to be 100% sure this is intentional.

Associated revisions

Revision 9c4e25da (diff)
Added by Brad Buckingham almost 5 years ago

fixes #12525 - clean up error message when enabling RH repository

With the introduction of docker content in a RH manifest, the input
parameters for enabling/disabling a repository were relaxed. In other
words, we removed releasever and basearch from being required.

This leads to errors like the following being reported to the user
if they omitted those parameters:

{} are not valid substitutions for /content/dist/rhel/server/7/$releasever/$basearch/kickstart

This commit will alter that message more like what they saw prior
to the docker change:

Missing arguments releasever, basearch for /content/dist/rhel/server/7/$releasever/$basearch/kickstart

Revision 25bc6152
Added by Brad Buckingham almost 5 years ago

Merge pull request #5606 from bbuckingham/issue-12525

fixes #12525 - clean up error message when enabling RH repository

History

#1 Updated by The Foreman Bot almost 5 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Brad Buckingham
  • Pull request https://github.com/Katello/katello/pull/5606 added

#2 Updated by Brad Buckingham almost 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Eric Helms almost 5 years ago

  • Category set to API
  • Legacy Backlogs Release (now unused) set to 86
  • Triaged changed from No to Yes

Also available in: Atom PDF