Project

General

Profile

Refactor #12526

Rails 4 - Investigate restrict_with_error vs. restrict_with_exception

Added by Chris Peters over 6 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Branch:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Determine the intended behavior when failing to destroy an object. During the upgrade we tried to modify as little of the underlying behavior as possible to make the tests pass. There were certain situations were we had to make some assumptions on the intended behavior. Do a deep dive into the model relations and determine when errors should be raised vs. exceptions.

History

#1 Updated by Eric Helms over 6 years ago

  • Status changed from New to Resolved

#2 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF