Project

General

Profile

Bug #12556

Remove System and Hypervsior models/controllers/tests/actions

Added by Justin Sherrill over 3 years ago. Updated about 1 year ago.


Description

As part of host unification remove all this old stuff


Related issues

Related to Katello - Bug #15646: Remove systems controller from apipie dataResolved2016-07-11
Is duplicate of Katello - Bug #13902: MIgrate hosts via content view version deletion instead of systemsDuplicate2016-02-25
Blocks Katello - Feature #11435: Host Unification TrackerNew2015-08-19

Associated revisions

Revision f5dcf970 (diff)
Added by Justin Sherrill about 3 years ago

Refs #12556 - Remove job model (#6103)

Revision df4bc4d7 (diff)
Added by Justin Sherrill about 3 years ago

Refs #12556 - Remove smart proxy system assoc (#6104)

as it is no longer used at all

Revision 440b51d5 (diff)
Added by Justin Sherrill about 3 years ago

Refs #12556 - remove System from views & controllers (#6156)

This attempts to remove any references to the System
model from all controllers and views. The only exception to
this is the CandlepinProxies controller which relies on creation and
updating of the models during sub-man actions. These will be removed
along with the model.

Some areas to test more heavily are: * Content View Version Removal * Various Content Host pages

A followup commit will remove the model and tests.

Revision 37fa1d79 (diff)
Added by Justin Sherrill almost 3 years ago

Refs #12556 - remove system subcommand

Revision 5873b91d
Added by Andrew Kofink almost 3 years ago

Merge pull request #424 from jlsherrill/12556

Refs #12556 - remove system subcommand

Revision dfa42c3b (diff)
Added by Justin Sherrill almost 3 years ago

Refs #12556 - fix content host reference

Revision 972909cd
Added by Andrew Kofink almost 3 years ago

Merge pull request #425 from jlsherrill/remove

Refs #12556 - fix content host reference

Revision 91599327 (diff)
Added by Justin Sherrill almost 3 years ago

Fixes #12556 - remove System model

Revision 558b8f11
Added by Justin Sherrill almost 3 years ago

Merge pull request #6187 from jlsherrill/remove_system_model

Fixes #12556 - remove System model

History

#1 Updated by Justin Sherrill over 3 years ago

#2 Updated by Eric Helms over 3 years ago

  • Legacy Backlogs Release (now unused) set to 86
  • Triaged changed from No to Yes

#3 Updated by Eric Helms about 3 years ago

  • Legacy Backlogs Release (now unused) changed from 86 to 143

#4 Updated by The Foreman Bot about 3 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Justin Sherrill
  • Pull request https://github.com/Katello/katello/pull/6103 added

#5 Updated by The Foreman Bot about 3 years ago

  • Pull request https://github.com/Katello/katello/pull/6104 added

#6 Updated by The Foreman Bot about 3 years ago

  • Pull request https://github.com/Katello/katello/pull/6156 added

#7 Updated by Justin Sherrill about 3 years ago

  • Legacy Backlogs Release (now unused) changed from 143 to 162

#8 Updated by Andrew Kofink about 3 years ago

  • Related to Bug #15646: Remove systems controller from apipie data added

#9 Updated by The Foreman Bot about 3 years ago

  • Pull request https://github.com/Katello/katello/pull/6187 added

#10 Updated by The Foreman Bot almost 3 years ago

  • Pull request https://github.com/Katello/hammer-cli-katello/pull/424 added

#11 Updated by The Foreman Bot almost 3 years ago

  • Pull request https://github.com/Katello/hammer-cli-katello/pull/425 added

#12 Updated by Bryan Kearney almost 3 years ago

  • Bugzilla link set to 1330072

#13 Updated by Justin Sherrill almost 3 years ago

  • Is duplicate of Bug #13902: MIgrate hosts via content view version deletion instead of systems added

#14 Updated by Justin Sherrill almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF