Project

General

Profile

Bug #12564

URI does not downcase scheme in Rails 4

Added by Daniel Lobato Garcia over 6 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Tests on spec/helpers/katello_url_helper_spec.rb fail on Rails 4, because URI.parse(url).scheme will return scheme without downcasing it. We can add a fix for this helper in a backwards-compatible manner.


Related issues

Is duplicate of Katello - Bug #12672: katello_url_helper ruby 2.2.2 compatibleResolved2015-12-02

History

#1 Updated by The Foreman Bot over 6 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5623 added

#2 Updated by Eric Helms over 6 years ago

  • Status changed from Ready For Testing to Duplicate
  • Triaged changed from No to Yes

#3 Updated by Eric Helms over 6 years ago

  • Is duplicate of Bug #12672: katello_url_helper ruby 2.2.2 compatible added

#4 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF