Project

General

Profile

Bug #12615

Bundler pack could not find compatible versions for gem "tins" on 1.9

Added by Dominic Cleal about 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Packaging
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Debian package builds on Wheezy and Precise (both Ruby 1.9.3) are failing to pack bundler files:

11:15:39 /usr/bin/bundle pack
11:15:40 Fetching gem metadata from https://rubygems.org/........
11:15:49 Fetching gem metadata from https://rubygems.org/..
11:15:51 Bundler could not find compatible versions for gem "tins":
11:15:51 In Gemfile:
11:15:51 rubocop (= 0.35.1) ruby depends on
11:15:51 tins (<= 1.6.0) ruby
11:15:51
11:15:51 term-ansicolor (>= 0) ruby depends on
11:15:51 tins (1.7.0)


Related issues

Related to Foreman - Feature #12530: Upgrade rubocop to 0.35.1Closed2015-11-19
Related to Foreman - Bug #12431: tins 1.7.0 requires Ruby 2.0 or higherClosed2015-11-10

Associated revisions

Revision eafe8e77 (diff)
Added by Dominic Cleal about 4 years ago

fixes #12615 - remove unused term-ansicolor dependency

Under Ruby 1.9.3, `bundle pack` is usually failing to resolve the tins
dependency between rubocop and term-ansicolor.

Remove the term-ansicolor dependency, which appears to be a development-
only dep of pry's coderay dep. coderay's syntax colour support works
fine without it at runtime.

History

#1 Updated by Dominic Cleal about 4 years ago

#2 Updated by Dominic Cleal about 4 years ago

  • Related to Bug #12431: tins 1.7.0 requires Ruby 2.0 or higher added

#3 Updated by David Davis about 4 years ago

Not sure how much it helps us but rubocop has since removed the tins requirement:

https://github.com/bbatsov/rubocop/commit/dfa1f9b6a2ad2f3d0d7e97a481665f68d4097f17#diff-458bc38d82061cdac508dfb1be2b918bL48

#4 Updated by Dominic Cleal about 4 years ago

Unsure if this is an intermittent issue or something has changed subtly to prevent it, as the latest nightly build succeeded:

http://ci.theforeman.org/job/packaging_build_deb_coreproject/arch=x86,label=debian,os=trusty/2632/consoleFull

I'll continue to monitor it.

#6 Updated by Dominic Cleal about 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Dominic Cleal

#7 Updated by The Foreman Bot about 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2956 added

#8 Updated by Dominic Cleal about 4 years ago

Running bundle pack --all under Ruby 1.9.3 without an existing Gemfile.lock seems to reproduce it for me locally.

#9 Updated by Dominic Cleal about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF