Bundler pack could not find compatible versions for gem "tins" on 1.9
Debian package builds on Wheezy and Precise (both Ruby 1.9.3) are failing to pack bundler files:
11:15:39 /usr/bin/bundle pack
11:15:40 Fetching gem metadata from https://rubygems.org/........
11:15:49 Fetching gem metadata from https://rubygems.org/..
11:15:51 Bundler could not find compatible versions for gem "tins":
11:15:51 In Gemfile:
11:15:51 rubocop (= 0.35.1) ruby depends on
11:15:51 tins (<= 1.6.0) ruby
11:15:51 term-ansicolor (>= 0) ruby depends on
11:15:51 tins (1.7.0)
fixes #12615 - remove unused term-ansicolor dependency
Under Ruby 1.9.3, `bundle pack` is usually failing to resolve the tins
dependency between rubocop and term-ansicolor.
Remove the term-ansicolor dependency, which appears to be a development-
only dep of pry's coderay dep. coderay's syntax colour support works
fine without it at runtime.
#3 Updated by David Davis about 4 years ago
Not sure how much it helps us but rubocop has since removed the tins requirement:
#4 Updated by Dominic Cleal about 4 years ago
Unsure if this is an intermittent issue or something has changed subtly to prevent it, as the latest nightly build succeeded:
I'll continue to monitor it.
#5 Updated by Dominic Cleal about 4 years ago
Still failing sometimes: http://ci.theforeman.org/job/packaging_build_deb_coreproject/2635