Project

General

Profile

Feature #12671

Move Ubuntu 14.04 Foreman package to Ruby 2.0.0

Added by Dominic Cleal about 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Debian/Ubuntu
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

It appears that Ubuntu 14.04 (trusty) ships Ruby 2.0.0 packages which we could use to run Foreman under, instead of the default 1.9.3.

http://packages.ubuntu.com/trusty/ruby/ruby2.0

We could probably replicate what we did in #7227 for 12.04 by adding a foreman-ruby symlink or something.


Related issues

Blocks Foreman - Refactor #8884: Drop Ruby 1.9.3 supportClosed2015-01-09

Associated revisions

Revision 400b5c51 (diff)
Added by Dominic Cleal about 4 years ago

fixes #12671 - switch Ubuntu 14.04 to ruby2.0 packages

History

#1 Updated by Dominic Cleal about 4 years ago

#2 Updated by Dominic Cleal about 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Dominic Cleal

#3 Updated by The Foreman Bot about 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-packaging/pull/908 added

#4 Updated by Dominic Cleal about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
  • Legacy Backlogs Release (now unused) set to 71

Also available in: Atom PDF