Project

General

Profile

Feature #12690

Unable to upload SRPMs

Added by Brian Shaw over 3 years ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Content Uploads
Target version:
Difficulty:
medium
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When I try to upload a source RPM (SRPM) to a company internal Product/Repo, hammer shows success but, the package never appears in the repo and Dynflow shows: Error uploading an RPM. The specified file is a source rpm

I have two questions, 1) Why does hammer show success when it is not. And, 2) what do I need to do to make this process work correctly?

Thank you for your help with this.


Related issues

Is duplicate of Katello - Feature #16712: Unable to upload source RPM packagesNew2016-09-27

History

#1 Updated by Dominic Cleal over 3 years ago

  • Project changed from Hammer CLI to Katello
  • Triaged set to No

#2 Updated by Eric Helms over 3 years ago

  • Tracker changed from Support to Bug
  • Legacy Backlogs Release (now unused) set to 86

#3 Updated by Eric Helms about 3 years ago

  • Legacy Backlogs Release (now unused) changed from 86 to 144

#4 Updated by Eric Helms about 3 years ago

  • Legacy Backlogs Release (now unused) changed from 144 to 168

#5 Updated by Eric Helms about 3 years ago

  • Legacy Backlogs Release (now unused) deleted (168)

#6 Updated by David Davis about 3 years ago

  • Tracker changed from Bug to Feature

We fixed the first problem around falsely reporting success here:

http://projects.theforeman.org/issues/14949

Should be in Katello 3.1. We don't currently support uploading SRPMs so I am changing this to a feature.

#7 Updated by Justin Sherrill about 3 years ago

  • Category set to Content Uploads
  • Legacy Backlogs Release (now unused) set to 114
  • Difficulty set to medium

#8 Updated by David Davis over 2 years ago

  • Status changed from New to Duplicate

#9 Updated by David Davis over 2 years ago

  • Is duplicate of Feature #16712: Unable to upload source RPM packages added

Also available in: Atom PDF