Project

General

Profile

Bug #12705

Issue warning when TFTP is not set on the Subnet

Added by Bryan Kearney over 3 years ago. Updated about 2 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Discovery plugin
Target version:
-
Difficulty:
trivial
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1287962
Description of problem:

When provisioning a host with discovery if the host's subnet does not have a tftp proxy configured the discovered host will reboot and go back into the discovery mode. Foreman should be able to recognize this situation and at least warn the user that this is not configured.

I'm not positive if there is even a use case for the tftp proxy to not be associated to the subnet in this sceanrio, so we may want to block the discovery provisioning attempt if not.

At least one customer has hit this.

Version-Release number of selected component (if applicable):
6.1.4

How reproducible:
Always

Steps to Reproduce:
1. Configure pxe discovery but do not associate the subnet with a tftp proxy/capsule
2. boot a system on that subnet
3. attempt to provision it

Actual results:
System reboots and goes back into discover

Expected results:
At least a warning is given to inform the user the tftp proxy is not configured on the subnet.

Additional info:


Related issues

Is duplicate of Discovery - Bug #9563: Provision should not be allowed when subnet doesn't have proxies set upDuplicate2015-02-26

History

#1 Updated by Lukas Zapletal over 3 years ago

  • Category set to Discovery plugin
  • Priority changed from Normal to Low

Well, if you don't have TFTP set, no provisioning will be orchestrated. That has nothing to do with Discovery :-)

I am unlikely to give this a priority as plugins are not able to do stuff like UI warnings without Deface gem. But I could issue a Flash warning message during provisioning, this will only work with one host provisioning tho. If you can help me reviewing and testing the patch, let me know.

#2 Updated by Lukas Zapletal over 3 years ago

  • Subject changed from Discovery does not warn if subnet does not have tftp proxy configured when provisioning a host to Issue warning when TFTP is not set on the Subnet

And this will not work with API/CLI as well. The proper way would be to warn during Subnet save. Might be possible via AR hooks/validations tho.

#3 Updated by Lukas Zapletal over 3 years ago

Note: Not having a TFTP set is not a valid option today, but in future (Image-Based provisioning, a patch is pending) this will be valid setup!

#4 Updated by Lukas Zapletal about 3 years ago

  • Is duplicate of Bug #9563: Provision should not be allowed when subnet doesn't have proxies set up added

#5 Updated by Lukas Zapletal about 3 years ago

  • Priority changed from Low to Normal
  • Target version set to Discovery Plugin 5.0.0

We should definitely issue an error when other proxies are not set up tho.

#6 Updated by Lukas Zapletal about 3 years ago

  • Status changed from New to Closed

#7 Updated by Eric Helms about 3 years ago

  • Status changed from Closed to Duplicate

#8 Updated by Lukas Zapletal about 3 years ago

  • Status changed from Duplicate to New

Eric, I closed the other one as duplicate. I want to keep the one with linked BZ.

#9 Updated by Lukas Zapletal about 2 years ago

  • Assignee deleted (Lukas Zapletal)
  • Target version deleted (Discovery Plugin 5.0.0)
  • Difficulty set to trivial

Also available in: Atom PDF