Project

General

Profile

Actions

Bug #12741

closed

Move non-ruby packages to katello metapackage

Added by Eric Helms over 8 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Difficulty:
medium
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

This was moved here from https://github.com/Katello/katello-packaging/issues/77

There are a lot of extra packages required by rubygem-katello.spec that, I think, are better suited for katello.spec instead:

#Pulp Requirements
Requires: pulp-katello
Requires: pulp-nodes-parent
Requires: pulp-docker-plugins
Requires: pulp-puppet-plugins
Requires: pulp-rpm-plugins
Requires: pulp-puppet-tools
Requires: pulp-selinux
Requires: pulp-server
Requires: mongodb >= 2.4
Requires: mongodb-server >= 2.4
Requires: cyrus-sasl-plain
Requires: python-crane
Requires: python-gofer-qpid
Requires: qpid-cpp-server-linearstore
Requires: qpid-cpp-client-devel
Requires: qpid-dispatch-router
Requires: candlepin-selinux
Requires: elasticsearch
Requires: createrepo >= 0.9.9-18%{?dist}
Requires: libvirt-devel
Requires: postgresql
Requires: postgresql-server

All of the above can exists on external machines without interfering with katello functionality.

Actions #1

Updated by The Foreman Bot over 8 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-packaging/pull/119 added
Actions #2

Updated by Eric Helms over 8 years ago

  • Status changed from Ready For Testing to Closed
  • Translation missing: en.field_release set to 86
Actions #3

Updated by Greg Sutcliffe almost 6 years ago

  • Target version deleted (Katello 3.0.0)
Actions

Also available in: Atom PDF