Project

General

Profile

Bug #12752

Host and hostgroup clone doesn't copy smart class parameters overrides

Added by Ori Rabin almost 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Smart Variables
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

When cloning a host/hg the smart class parameters/variables that are overridden do not clone their value.
The cloned host shows that these parameters are overridden but shows them with the original value.

This happens only through the UI, when cloning through API the lookup values are cloned.


Related issues

Related to Foreman - Refactor #11458: Allow overriding parameters inline in host & hostgroup formsClosed2015-08-24

Associated revisions

Revision e0e41840 (diff)
Added by Ori Rabin almost 4 years ago

Fixes #12752 - Host and hostgroup clone should copy smart class parameters overrides

History

#1 Updated by Ori Rabin almost 4 years ago

  • Description updated (diff)
  • Category changed from Smart Variables to Web Interface

#2 Updated by Dominic Cleal almost 4 years ago

  • Related to Bug #12609: Boolean parameter overrides are not displayed correctly on host form added

#3 Updated by Dominic Cleal almost 4 years ago

  • Category changed from Web Interface to Smart Variables
  • Legacy Backlogs Release (now unused) set to 71

#4 Updated by Tomer Brisker almost 4 years ago

  • Related to Refactor #11458: Allow overriding parameters inline in host & hostgroup forms added

#5 Updated by Tomer Brisker almost 4 years ago

  • Related to deleted (Bug #12609: Boolean parameter overrides are not displayed correctly on host form)

#6 Updated by Dominic Cleal almost 4 years ago

It seems to be working as of #11458, but not as of #12609. Either way, this seems to be a regression.

There is also a partial regression of 003359564, as I see invalid match/value errors on the clone form which were hidden before.

#7 Updated by The Foreman Bot almost 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2968 added

#8 Updated by Ori Rabin almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF