Project

General

Profile

Bug #12796

Running 'rake pkg:generate_source' fails with bundler 1.11.0

Added by Tomáš Strachota over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
High
Category:
Hammer core
Target version:
-
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

It's caused by https://github.com/bundler/bundler/issues/4149
Both hammer-cli and hammer-cli-foreman are affected. It's making our Jenkins test chain fail.

bundle
Resolving dependencies...
Using rake 10.1.1
Using json 1.8.3
Using oauth 0.4.7
Using unf_ext 0.0.7.1
Using mime-types 2.99
Using netrc 0.11.0
Using awesome_print 1.6.1
Using builder 3.2.2
Using byebug 8.2.1
Using clamp 1.0.0
Using coderay 1.1.0
Using docile 1.1.5
Using fast_gettext 1.0.0
Using locale 2.1.2
Using text 1.3.1
Using highline 1.7.8
Using little-plugger 1.1.4
Using multi_json 1.11.2
Using table_print 1.5.4
Using metaclass 0.0.4
Using method_source 0.8.2
Using minitest 4.7.4
Using minitest-spec-context 0.0.3
Using slop 3.6.0
Using ruby-prof 0.15.9
Using simplecov-html 0.10.0
Using thor 0.19.1
Using bundler 1.11.0
Using unf 0.1.4
Using ci_reporter 1.9.3
Using gettext 3.1.7
Using logging 2.0.0
Using mocha 1.1.0
Using pry 0.10.3
Using simplecov 0.11.1
Using domain_name 0.5.25
Using pry-byebug 3.3.0
Using http-cookie 1.0.2
Using rest-client 1.8.0
Using apipie-bindings 0.0.15
Using hammer_cli 0.4.0 from source at `.`
Using hammer_cli_foreman 0.4.0 from source at `../hammer-cli-foreman`
bundle exec rake pkg:generate_source
rake aborted!
/usr/local/rvm/rubies/ruby-2.0.0-p643/lib/ruby/2.0.0/x86_64-linux/psych.so: warning: already initialized constant Psych::Parser::ANY
/usr/local/rvm/rubies/ruby-2.0.0-p643/lib/ruby/2.0.0/x86_64-linux/psych.so: warning: already initialized constant Psych::Parser::UTF8
/usr/local/rvm/rubies/ruby-2.0.0-p643/lib/ruby/2.0.0/x86_64-linux/psych.so: warning: already initialized constant Psych::Parser::UTF16LE
/usr/local/rvm/rubies/ruby-2.0.0-p643/lib/ruby/2.0.0/x86_64-linux/psych.so: warning: already initialized constant Psych::Parser::UTF16BE
/usr/local/rvm/rubies/ruby-2.0.0-p643/lib/ruby/2.0.0/psych/syntax_error.rb:5:in `<module:Psych>': superclass mismatch for class SyntaxError (TypeError)
        from /usr/local/rvm/rubies/ruby-2.0.0-p643/lib/ruby/2.0.0/psych/syntax_error.rb:1:in `<top (required)>'
        from /usr/local/rvm/rubies/ruby-2.0.0-p643/lib/ruby/2.0.0/psych.rb:1:in `require'
        from /usr/local/rvm/rubies/ruby-2.0.0-p643/lib/ruby/2.0.0/psych.rb:1:in `<top (required)>'
        from /usr/local/rvm/rubies/ruby-2.0.0-p643/lib/ruby/site_ruby/2.0.0/rubygems.rb:609:in `require'
        from /usr/local/rvm/rubies/ruby-2.0.0-p643/lib/ruby/site_ruby/2.0.0/rubygems.rb:609:in `load_yaml'
        from /usr/local/rvm/rubies/ruby-2.0.0-p643/lib/ruby/site_ruby/2.0.0/rubygems/config_file.rb:328:in `load_file'
        from /usr/local/rvm/rubies/ruby-2.0.0-p643/lib/ruby/site_ruby/2.0.0/rubygems/config_file.rb:197:in `initialize'
        from /usr/local/rvm/rubies/ruby-2.0.0-p643/lib/ruby/site_ruby/2.0.0/rubygems/gem_runner.rb:74:in `new'
        from /usr/local/rvm/rubies/ruby-2.0.0-p643/lib/ruby/site_ruby/2.0.0/rubygems/gem_runner.rb:74:in `do_configuration'
        from /usr/local/rvm/rubies/ruby-2.0.0-p643/lib/ruby/site_ruby/2.0.0/rubygems/gem_runner.rb:39:in `run'
        from /usr/local/rvm/rubies/ruby-2.0.0-p643/bin/gem:21:in `<main>'
/usr/local/rvm/gems/ruby-2.0.0-p643/gems/bundler-1.11.0/lib/bundler/gem_helper.rb:170:in `sh'
/usr/local/rvm/gems/ruby-2.0.0-p643/gems/bundler-1.11.0/lib/bundler/gem_helper.rb:75:in `build_gem'
/usr/local/rvm/gems/ruby-2.0.0-p643/gems/bundler-1.11.0/lib/bundler/gem_helper.rb:39:in `block in install'
/usr/local/rvm/gems/ruby-2.0.0-p643/bin/ruby_executable_hooks:15:in `eval'
/usr/local/rvm/gems/ruby-2.0.0-p643/bin/ruby_executable_hooks:15:in `<main>'
Tasks: TOP => pkg:generate_source => build
(See full trace by running task with --trace)

Related issues

Related to Hammer CLI - Bug #12797: Remove explicit psych requireClosed2015-12-14

Associated revisions

Revision 55ccb20c (diff)
Added by Tomas Strachota over 4 years ago

Fixes #12796 - adding psych to the Gemfile

Requiring psych in Gemfile to workaround issues with bundler 1.11.0
See https://github.com/bundler/bundler/issues/4149 for more details.

Revision 907ad62e (diff)
Added by Tomas Strachota over 4 years ago

Fixes #12796 - adding psych to the Gemfile

Requiring psych in Gemfile to workaround issues with bundler 1.11.0
See https://github.com/bundler/bundler/issues/4149 for more details.

Revision 704f6fdd
Added by Tomas Strachota over 4 years ago

Merge pull request #189 from tstrachota/bundler_12796

Fixes #12796 - adding psych to the Gemfile

Revision 8e75821a
Added by Tomas Strachota over 4 years ago

Merge pull request #208 from tstrachota/bundler_12796

Fixes #12796 - adding psych to the Gemfile

History

#1 Updated by Dominic Cleal over 4 years ago

This is probably https://github.com/bundler/bundler/issues/4149, due to bundler 0.11.0 being released.

#2 Updated by Tomáš Strachota over 4 years ago

  • Subject changed from Running 'rake pkg:generate_source' fails with bundler 0.11 to Running 'rake pkg:generate_source' fails with bundler 1.11.0

#3 Updated by The Foreman Bot over 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/hammer-cli/pull/189 added

#4 Updated by The Foreman Bot over 4 years ago

  • Pull request https://github.com/theforeman/hammer-cli-foreman/pull/208 added

#5 Updated by Anonymous over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Tomáš Strachota over 4 years ago

  • Related to Bug #12797: Remove explicit psych require added

Also available in: Atom PDF