Project

General

Profile

Bug #12876

Foreman build can't find bundler 1.3 or higher on Wheezy/Precise

Added by Dominic Cleal over 5 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Debian/Ubuntu
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Builds of Foreman core are failing on Debian Wheezy and Ubuntu Precise as they can't find a matching Bundler version. #7230 increased the min version to 1.3 as a dep of Rails 4.1, but the distros have 1.1.4 and 1.0.15 respectively.

Builds fail with:

13:32:12 Bundler could not find compatible versions for gem "bundler":
13:32:12   In Gemfile:
13:32:12     rails (= 4.1.5) ruby depends on
13:32:12       bundler (< 2.0, >= 1.3.0) ruby
13:32:12 
13:32:12   Current Bundler version:
13:32:12     bundler (1.1.4)

(http://ci.theforeman.org/job/packaging_build_deb_coreproject/2693/arch=x86,label=debian,os=wheezy/console)

We'll probably need to ship our own newer package.


Related issues

Related to Foreman - Feature #7230: Upgrade Ruby on Rails to 4.1Closed2014-08-22
Blocks Foreman - Tracker #3157: Rails 4.1 upgrade tasksClosed2013-09-27

Associated revisions

Revision 08ad149f (diff)
Added by Michael Moll over 5 years ago

fixes #12876 - package bundler 1.3 for precise and wheezy

The Rails 4.1 gem depends on bundler >= 1.3.0, rendering the bundler
packages in the stock precise and wheezy archives unfeasible.

History

#1 Updated by Dominic Cleal over 5 years ago

#2 Updated by Dominic Cleal over 5 years ago

#3 Updated by The Foreman Bot over 5 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-packaging/pull/926 added

#4 Updated by Dominic Cleal over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF