Project

General

Profile

Bug #12893

already initialized constant warnings

Added by Ohad Levy over 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Rails
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When loading the application, the following kind of errors are reported:

foreman/lib/net/validations.rb:7: warning: already initialized constant Net::Validations::MASK_REGEXP
foreman/lib/net/validations.rb:7: warning: previous definition of MASK_REGEXP was here

Associated revisions

Revision c7521b7b (diff)
Added by Ohad Levy over 3 years ago

fixes #12893 - ensure constants are set only once

the root cause is probably the same file is loaded multiple times.

History

#1 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2996 added

#2 Updated by Ohad Levy over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Dominic Cleal over 3 years ago

  • Category set to Rails
  • Legacy Backlogs Release (now unused) set to 71

Also available in: Atom PDF