Project

General

Profile

Bug #12940

New Host pages does not accept the Oscap_Proxy host

Added by Kedar Bidarkar over 6 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

a) Install the oscap plugin with the needed packages
b) Make sure the Oscap Features is visiable under the "smart proxy"
c) Add oscap_policy and associate the valid stuff
d) Create a "New Host" and select the "Oscap Proxy" as the "default smart-proxy" , which turns red.

/var/log/foreman/production.log throws the below message:

2015-12-24 05:52:22 [app] [I] | | Started POST "/hosts/openscap_proxy_changed" for 10.65.193.142 at 2015-12-24 05:52:22 -0500
2015-12-24 05:52:22 [app] [I] Processing by HostsController#openscap_proxy_changed as */*
2015-12-24 05:52:22 [app] [I] Parameters: {"utf8"=>"✓", "authenticity_token"=>"TjessVmM3OW7NPdu0BWmILWS6XJaSOQpaEBlaDNW7nI=", "host"=>{"name"=>"kbidarkarhel7", "organization_id"=>"1", "location_id"=>"2", "hostgroup_id"=>"", "compute_resource_id"=>"4", "content_facet_attributes"=>{"lifecycle_environment_id"=>"2", "content_view_id"=>"5", "id"=>""}, "environment_id"=>"", "content_source_id"=>"1", "puppet_ca_proxy_id"=>"1", "puppet_proxy_id"=>"1", "openscap_proxy_id"=>"1", "managed"=>"true", "progress_report_id"=>"[FILTERED]", "type"=>"Host::Managed", "interfaces_attributes"=>{"0"=>{"_destroy"=>"0", "type"=>"Nic::Managed", "mac"=>"", "identifier"=>"", "name"=>"kbidarkarhel7", "domain_id"=>"", "subnet_id"=>"", "ip"=>"", "managed"=>"1", "primary"=>"1", "provision"=>"1", "virtual"=>"0", "tag"=>"", "attached_to"=>"", "compute_attributes"=>{"type"=>"bridge", "bridge"=>"eno1", "model"=>"virtio"}}, "new_interfaces"=>{"_destroy"=>"1", "type"=>"Nic::Managed", "mac"=>"", "identifier"=>"", "name"=>"", "domain_id"=>"", "subnet_id"=>"", "ip"=>"", "managed"=>"1", "primary"=>"0", "provision"=>"0", "virtual"=>"0", "tag"=>"", "attached_to"=>"", "compute_attributes"=>{"type"=>"bridge", "bridge"=>"eno1", "model"=>"virtio"}}}, "compute_attributes"=>{"cpus"=>"1", "memory"=>"805306368", "start"=>"1", "volumes_attributes"=>{"new_volumes"=>{"_delete"=>"", "pool_name"=>"default", "capacity"=>"10G", "allocation"=>"0G", "format_type"=>"raw"}, "0"=>{"_delete"=>"", "pool_name"=>"default", "capacity"=>"10G", "allocation"=>"0G", "format_type"=>"raw"}}}, "architecture_id"=>"", "provision_method"=>"build", "build"=>"1", "disk"=>"", "root_pass"=>"[FILTERED]", "is_owned_by"=>"3-Users", "enabled"=>"1", "model_id"=>"", "comment"=>"", "overwrite"=>"false"}, "capabilities"=>"build image", "provider"=>"Libvirt", "fakepassword"=>"[FILTERED]", "bare_metal_capabilities"=>"build", "host_id"=>"null"}
2015-12-24 05:52:22 [app] [I] Rendered common/404.html.erb within layouts/application (1.5ms)
2015-12-24 05:52:22 [app] [I] Rendered layouts/base.html.erb (1.3ms)
2015-12-24 05:52:22 [app] [I] Completed 404 Not Found in 23ms (Views: 4.4ms | ActiveRecord: 2.4ms)

We should be able to select the "oscap Proxy"

History

#1 Updated by Marek Hulán almost 6 years ago

  • Project changed from OpenSCAP (top-level) to OpenSCAP
  • Triaged set to No

#2 Updated by Ondřej Pražák 7 months ago

  • Status changed from New to Closed

This no longer seems to be an issue, closing. Feel free to reopen if I am mistaken.

Also available in: Atom PDF