Project

General

Profile

Bug #1296

Parsing puppet classes fails in certain cases

Added by Tray Torrance over 7 years ago. Updated over 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Puppet integration
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

I use many parameterized classes, but tend to set default values so that the classes can be used in a non-parameterized fashion. For one class (puppet::configure), I utilized line-wrapping to spread the parameters over multiple lines, and enhance readability. This causes foreman to no longer parse that class as valid.

Example class is attached.

configure.pp configure.pp 1.5 KB Tray Torrance, 11/04/2011 03:14 PM

Related issues

Is duplicate of Foreman - Bug #1299: foreman don't cut the () from puppet class namesClosed2011-11-07

History

#1 Updated by Ohad Levy over 7 years ago

  • Target version set to 0.4

#2 Updated by Ohad Levy over 7 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF