Project

General

Profile

Bug #12995

I can' t delete my host

Added by Thomas Rohlik almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hello,
I want delete one of my host via "Delete" button on host details, but error occurs:

Warning!
undefined method `delete' for nil:NilClass

I attach the full trace log.

log.txt log.txt 12.9 KB Thomas Rohlik, 01/05/2016 05:42 AM

Related issues

Related to Foreman - Support #14177: dns-problems when provision a hostResolved2016-03-14
Has duplicate Salt - Bug #13063: Cannot delete hostDuplicate2016-01-08
Has duplicate Salt - Bug #14103: Delete Host runs in Exception -> undefined method `delete' for nil:NilClassDuplicate2016-03-08

History

#1 Updated by Thomas Rohlik almost 6 years ago

I using Libvirt provider for host.

#2 Updated by Dominic Cleal almost 6 years ago

  • Project changed from Foreman to Salt

This is a bug in foreman_salt which appears to have been fixed in master, but not in a release yet.

https://github.com/theforeman/foreman_salt/pull/53

#3 Updated by Thomas Rohlik almost 6 years ago

Thx Dominic.
I use that patch and I can delete my host without problem now.

#4 Updated by Stephen Benjamin almost 6 years ago

  • Status changed from New to Resolved

Thanks! Closing since the issue is fixed in master

#5 Updated by Dominic Cleal almost 6 years ago

  • Has duplicate Bug #13063: Cannot delete host added

#6 Updated by Dominic Cleal over 5 years ago

  • Has duplicate Bug #14103: Delete Host runs in Exception -> undefined method `delete' for nil:NilClass added

#7 Updated by Dominic Cleal over 5 years ago

Also available in: Atom PDF