Project

General

Profile

Bug #13004

Compute Profiles not Inheriting from nested host group

Added by Chris Pisano over 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Host creation
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

I am running Foreman 1.10 and provisioning new hosts to VMware using template based provisioning. It appears that the configurations of my Compute Profiles are not being inherited to the Virtual Machine tab when building a new host. My host group has a default Compute profile assigned to it. It seems if I uninherit the compute profile and remove it then reselect it everything is inherited fine. I've attached a short 1minute video of my build process showing exactly what I am doing.

Foreman Compute Profile Bug.mp4 Foreman Compute Profile Bug.mp4 853 KB video of host build Chris Pisano, 01/05/2016 09:51 AM
hostgroup debug.txt hostgroup debug.txt 162 KB Chris Pisano, 01/13/2016 09:20 AM
computeresource debug.txt computeresource debug.txt 52.2 KB Chris Pisano, 01/13/2016 09:20 AM

Related issues

Related to Foreman - Bug #12461: Compute profiles are not applied when inheritedClosed2015-11-12
Has duplicate Foreman - Bug #13145: compute profile not applied when interited from host groupDuplicate2016-01-12

Associated revisions

Revision 05d9c49e (diff)
Added by Dominic Cleal over 3 years ago

fixes #13004 - inherit compute profile from parent host groups

When selecting a compute resource on the New Host form and the VM
attributes tab is refreshed using an inherited compute profile, the
profile was taken from the host group only if explicitly set on it. The
compute profile is now inherited from the host group parent if set.

Revision 69e3337e (diff)
Added by Dominic Cleal over 3 years ago

fixes #13004 - inherit compute profile from parent host groups

When selecting a compute resource on the New Host form and the VM
attributes tab is refreshed using an inherited compute profile, the
profile was taken from the host group only if explicitly set on it. The
compute profile is now inherited from the host group parent if set.

History

#1 Updated by Dominic Cleal over 3 years ago

  • Legacy Backlogs Release (now unused) set to 104

Thanks for the video, that's excellent.

#2 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #12461: Compute profiles are not applied when inherited added

#3 Updated by Dominic Cleal over 3 years ago

  • Has duplicate Bug #13145: compute profile not applied when interited from host group added

#4 Updated by Dominic Cleal over 3 years ago

I'm unable to reproduce this on either develop or 1.10 at the moment. Could you attach the production.log output during the selection of the host group, and also when selecting the compute resource immediately after (steps at 0:13, 0:18 of the video) please?

#5 Updated by Chris Pisano over 3 years ago

Dominic Cleal wrote:

I'm unable to reproduce this on either develop or 1.10 at the moment. Could you attach the production.log output during the selection of the host group, and also when selecting the compute resource immediately after (steps at 0:13, 0:18 of the video) please?

Attached are debug logs immediately after selecting a host group and immediately after selecting the compute resource. I think some unrelated logs might have slipped in while the compute resource was being resolved. . . my apologies for that. Please let me know if you need anything else. I just did some tests and it does seem that this is only an issue when inheriting a compute profile from a host group.

#6 Updated by Dominic Cleal over 3 years ago

  • Subject changed from Compute Profiles not Inheriting to Compute Profiles not Inheriting from nested host group
  • Status changed from New to Assigned
  • Assignee set to Dominic Cleal

Thanks for the extra data, that was helpful. I think I see when it happens now - when a profile is inherited from a parent/nested host group, it doesn't resolve. If your profile was set on the child group (rather than "Inherit parent") then it would probably work.

#7 Updated by Chris Pisano over 3 years ago

Dominic Cleal wrote:

Thanks for the extra data, that was helpful. I think I see when it happens now - when a profile is inherited from a parent/nested host group, it doesn't resolve. If your profile was set on the child group (rather than "Inherit parent") then it would probably work.

You are correct. I created a parent group with no compute profile set and a nested group with a compute profile set. Everything is inherited without issue.

#8 Updated by The Foreman Bot over 3 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3071 added

#9 Updated by Dominic Cleal over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF