Project

General

Profile

Bug #13018

Hitting a 401 error when registering capsule during a dev install

Added by David Davis over 6 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Here's the error:

 /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[hesperus.usersys.redhat.com]: Could not evaluate: Proxy hesperus.usersys.redhat.com cannot be registered (401 Unauthorized): N/A
 /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[hesperus.usersys.redhat.com]: Failed to call refresh: Proxy hesperus.usersys.redhat.com cannot be registered (Proxy hesperus.usersys.redhat.com cannot be registered (401 Unauthorized): N/A): N/A
 /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[hesperus.usersys.redhat.com]: Proxy hesperus.usersys.redhat.com cannot be registered (Proxy hesperus.usersys.redhat.com cannot be registered (401 Unauthorized): N/A): N/A

The corresponding development.log:

ESC[32m2016-01-06T08:44:34ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m] Started GET "/apidoc/v2.json" for 127.0.0.1 at 2016-01-06 08:44:34 -0500
ESC[32m2016-01-06T08:44:35ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m] Processing by Apipie::ApipiesController#index as JSON
ESC[32m2016-01-06T08:44:35ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m]   Parameters: {"version"=>"v2.json", "apipy"=>{}}
ESC[32m2016-01-06T08:45:09ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m] Completed 200 OK in 33858ms (Views: 1086.0ms | ActiveRecord: 367.5ms)
ESC[32m2016-01-06T08:45:14ESC[0m [ESC[36mappESC[0m] [D] 
ESC[32m2016-01-06T08:45:14ESC[0m [ESC[36mappESC[0m] [D] 
ESC[32m2016-01-06T08:45:14ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m] Started GET "/api/smart_proxies?search=name%3Dhesperus.usersys.redhat.com" for 127.0.0.1 at 2016-01-06 08:45:14 -0500
ESC[32m2016-01-06T08:45:15ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m] Processing by Api::V2::SmartProxiesController#index as JSON
ESC[32m2016-01-06T08:45:15ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m]   Parameters: {"search"=>"name=hesperus.usersys.redhat.com", "apiv"=>"v2", "smart_proxy"=>{}}
ESC[32m2016-01-06T08:45:16ESC[0m [ESC[36mappESC[0m] [ESC[33mWESC[0m] Oauth: mapping to user '' failed
ESC[32m2016-01-06T08:45:16ESC[0m [ESC[36mappESC[0m] [ESC[33mWESC[0m] SSO failed
ESC[32m2016-01-06T08:45:16ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m]   Rendered api/v2/errors/unauthorized.json.rabl within api/v2/layouts/error_layout (1.4ms)
ESC[32m2016-01-06T08:45:16ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m] Filter chain halted as :authorize rendered or redirected
ESC[32m2016-01-06T08:45:16ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m] Completed 401 Unauthorized in 1398ms (Views: 815.6ms | ActiveRecord: 10.5ms)
ESC[32m2016-01-06T08:45:16ESC[0m [ESC[36mappESC[0m] [D] 
ESC[32m2016-01-06T08:45:16ESC[0m [ESC[36mappESC[0m] [D] 
ESC[32m2016-01-06T08:45:16ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m] Started GET "/api/smart_proxies?search=name%3Dhesperus.usersys.redhat.com" for 127.0.0.1 at 2016-01-06 08:45:16 -0500
ESC[32m2016-01-06T08:45:16ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m] Processing by Api::V2::SmartProxiesController#index as JSON
ESC[32m2016-01-06T08:45:16ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m]   Parameters: {"search"=>"name=hesperus.usersys.redhat.com", "apiv"=>"v2", "smart_proxy"=>{}}
ESC[32m2016-01-06T08:45:16ESC[0m [ESC[36mappESC[0m] [ESC[33mWESC[0m] Oauth: mapping to user '' failed
ESC[32m2016-01-06T08:45:16ESC[0m [ESC[36mappESC[0m] [ESC[33mWESC[0m] SSO failed
ESC[32m2016-01-06T08:45:16ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m]   Rendered api/v2/errors/unauthorized.json.rabl within api/v2/layouts/error_layout (0.8ms)
ESC[32m2016-01-06T08:45:16ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m] Filter chain halted as :authorize rendered or redirected
ESC[32m2016-01-06T08:45:16ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m] Completed 401 Unauthorized in 12ms (Views: 6.2ms | ActiveRecord: 0.5ms)
ESC[32m2016-01-06T08:45:18ESC[0m [ESC[36mappESC[0m] [D] 
ESC[32m2016-01-06T08:45:18ESC[0m [ESC[36mappESC[0m] [D] 
ESC[32m2016-01-06T08:45:18ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m] Started POST "/api/reports" for 127.0.0.1 at 2016-01-06 08:45:18 -0500
ESC[32m2016-01-06T08:45:19ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m] Processing by Api::V2::ReportsController#create as JSON
ESC[32m2016-01-06T08:45:19ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m]   Parameters: {"report"=>"[FILTERED]", "apiv"=>"v2"}
ESC[32m2016-01-06T08:45:19ESC[0m [ESC[36mappESC[0m] [ESC[33mWESC[0m] DEPRECATION WARNING: Your API call uses deprecated behavior, The resources /reports were moved to /config_reports. Please use the new path instead. (called from deprecated at /home/dadavis/Projects/foreman/app/controllers/api/v2/reports_controller.rb:66)
ESC[32m2016-01-06T08:45:19ESC[0m [ESC[36mappESC[0m] [ESC[33mWESC[0m] No SSL cert with CN supplied - request from 127.0.0.1, 
ESC[32m2016-01-06T08:45:19ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m]   Rendered api/v2/errors/access_denied.json.rabl within api/v2/layouts/error_layout (2.0ms)
ESC[32m2016-01-06T08:45:19ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m] Filter chain halted as #<Proc:0x0000000bbea5b8@/home/dadavis/Projects/foreman/app/controllers/concerns/foreman/controller/smart_proxy_auth.rb:14> rendered or redirected
ESC[32m2016-01-06T08:45:19ESC[0m [ESC[36mappESC[0m] [ESC[32mIESC[0m] Completed 403 Forbidden in 103ms (Views: 8.5ms | ActiveRecord: 6.5ms)

Related issues

Is duplicate of Foreman - Bug #13230: Oauth headers are no longer working with rails 4Closed2016-01-14

History

#1 Updated by Eric Helms over 6 years ago

  • Status changed from New to Duplicate

#2 Updated by Eric Helms over 6 years ago

  • Is duplicate of Bug #13230: Oauth headers are no longer working with rails 4 added

#3 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF