Project

General

Profile

Bug #13028

foreman-proxy has error "Couldn't enable plugin dhcp_isc" on every restart

Added by Thomas McKay over 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Plugins
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

I've tried to set :enable:false in the settings.d and the error continues to appear. The proxy says it is active and running but the error is concerning.

E, [2016-01-06T03:10:02.398704 #11034] ERROR -- : Couldn't enable plugin dhcp_isc: File at '/etc/dhcp/dhcpd.conf' defined in 'config' parameter doesn't exist or is unreadable


Related issues

Related to Smart Proxy - Bug #13600: Templates module not marked as failed when foreman_url is missingClosed2016-02-08

Associated revisions

Revision 53e560fe (diff)
Added by Dmitri Dolguikh over 4 years ago

Fixes #13028: provider will not be configured if the main plugin is disabled

Also made plugin initialization and configuration more testable.

History

#1 Updated by Dmitri Dolguikh over 4 years ago

  • Project changed from Foreman to Smart Proxy
  • Category changed from Proxy gateway to Plugins

#2 Updated by Dmitri Dolguikh over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Dmitri Dolguikh

#3 Updated by The Foreman Bot over 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/smart-proxy/pull/364 added

#4 Updated by Dominic Cleal over 4 years ago

  • Related to Bug #13600: Templates module not marked as failed when foreman_url is missing added

#5 Updated by Anonymous over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Dominic Cleal over 4 years ago

  • Legacy Backlogs Release (now unused) set to 71

#7 Updated by Lukas Zapletal about 4 years ago

For the record, root cause of your error was most likely upgrade of dhcp daemon package which reset permissions on /etc/dhcp directory and config files. To fix this use:

chown -R root:foreman-proxy /etc/dhcp

I wonder if it makes sense to do this in foreman-proxy post installation scriplet. Puppet does this, but users don't run it during upgrades...

Also available in: Atom PDF