Project

General

Profile

Feature #13055

Provide helper for plugins to register buttons

Added by Stephen Benjamin over 4 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Plugin integration
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

E.g. salt has actions like "Salt Keys" and "Autosign" that apply to the proxy, so we should let the plugin register these as actions


Related issues

Is duplicate of Foreman - Feature #12716: As a foreman developer I'd like to have way of extending the data returned from smart proxy api.Closed2015-12-07

History

#1 Updated by Stephen Benjamin over 4 years ago

  • Tracker changed from Bug to Feature
  • Assignee set to Stephen Benjamin

#2 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3032 added

#3 Updated by Stephen Benjamin over 4 years ago

  • Subject changed from Provide helper for plugins to add smart proxy buttons to Provide helper for plugins to register buttons
  • Status changed from Ready For Testing to New

Ohad suggested making this a bigger scope, by having some kind of master button registry. See the conversation on https://github.com/theforeman/foreman/pull/3032

#4 Updated by Stephen Benjamin over 4 years ago

  • Pull request deleted (https://github.com/theforeman/foreman/pull/3032)

#5 Updated by Stephen Benjamin over 3 years ago

  • Assignee deleted (Stephen Benjamin)

#6 Updated by Dominic Cleal over 3 years ago

  • Is duplicate of Feature #12716: As a foreman developer I'd like to have way of extending the data returned from smart proxy api. added

#7 Updated by Dominic Cleal over 3 years ago

  • Status changed from New to Duplicate

#12716 provides extension points via Pagelets for smart_proxy_title_actions on the smart proxy index and show pages. See http://projects.theforeman.org/projects/foreman/wiki/How_to_Create_a_Plugin#Adding-a-Pagelet for more info.

Also available in: Atom PDF