Project

General

Profile

Bug #13127

The Hidden Value checkbox is disabled for Parameter with empty puppet default Value,

Added by Jitendra Yejare almost 6 years ago. Updated almost 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Parameters
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1297736
Description of problem:
The 'Hidden Value' checkbox is disabled for Parameter having empty puppet default value.

Version-Release number of selected component (if applicable):
foreman-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Import a puppet class parameter with empty puppet default value.
2. In Config - > Smart Class Parameters - > Parameter - > Check Override Button.
3. Don't set any default value. leave it as blank only.
4. Check 'Hidden Value' checkbox.

Actual results:
The 'Hidden Value' checkbox is disabled to check.

Expected results:
The 'Hidden Value' checkbox should be enabled even if puppet default value empty.

Additional info:


Related issues

Is duplicate of Foreman - Bug #12828: Hidden value checkbox disabled after override button is checkedClosed2015-12-15

History

#1 Updated by Dominic Cleal almost 6 years ago

  • Category set to Parameters
  • Status changed from New to Need more information
  • Assignee deleted (Ori Rabin)

You're using a very old nightly, please use a current version of the develop branch with the fix from #12828 and confirm if the bug is still present.

#2 Updated by Dominic Cleal almost 6 years ago

  • Status changed from Need more information to Duplicate

#3 Updated by Dominic Cleal almost 6 years ago

  • Is duplicate of Bug #12828: Hidden value checkbox disabled after override button is checked added

Also available in: Atom PDF