Project

General

Profile

Bug #1315

Short hostname confusion

Added by Bryan McPhall over 7 years ago. Updated over 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

My CentOS servers have many similar names:

web1.green.example.com
web2.green.example.com
web1.purple.example.com
web2.purple.example.com

This is confusing in my host list as I see many hosts and web1, web2, etc.

In Foreman 0.3 I could edit the name of the server from web1 to web1.green and change the hostname to example.com. These changes would revert everytime I would import new puppet classes and environments.

In version 0.4, when I import new puppet classes and environments, the name reverts back to web1 and I cannot change it. This makes for a confusing host list.


Related issues

Is duplicate of Foreman - Feature #165: Subdomain should be shown for hostname.Duplicate2010-02-03
Is duplicate of Foreman - Bug #1303: Column widths for long text in 0.4Closed2011-11-09

History

#1 Updated by Bash Shell over 7 years ago

This is duplicate of #165 .

#2 Updated by Ohad Levy over 7 years ago

  • Status changed from New to Duplicate
  • Target version set to 0.4.1

actually, they are both a duplicate of #1303

Also available in: Atom PDF